summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonuk Raval2019-05-05 17:45:02 -0400
committerRonuk Raval2019-05-05 17:45:02 -0400
commita7657b72b21795b7275d309cdca7e1c73bcf719a (patch)
tree854ddb6fffc227547ab0c83768a0c33e736f7860
downloadaur-a7657b72b21795b7275d309cdca7e1c73bcf719a.tar.gz
v0.7.1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03757a41f99b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-pscript
+ pkgdesc = Python to JavaScript compiler
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = https://pscript.readthedocs.io
+ arch = any
+ license = BSD
+ depends = python
+ source = python-pscript-0.7.1.tar.gz::https://github.com/flexxui/pscript/archive/v0.7.1.tar.gz
+ sha256sums = 8539caefe6b8f97f0f80fccb57076c9a6a7fef4773dc039f3a0286c8bc962fff
+
+pkgname = python-pscript
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4c64ba006d18
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg
+/src
+/*.pkg.tar
+/*.pkg.tar.xz
+/python-pscript-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f84d746aa30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ronuk Raval <ronuk.raval at gmail dot com>
+
+pkgname=python-pscript
+pkgver=0.7.1
+pkgrel=1
+pkgdesc="Python to JavaScript compiler"
+arch=('any')
+url="https://pscript.readthedocs.io"
+license=('BSD')
+depends=(python)
+source=(
+ ${pkgname}-${pkgver}.tar.gz::https://github.com/flexxui/pscript/archive/v${pkgver}.tar.gz
+)
+sha256sums=(
+ 8539caefe6b8f97f0f80fccb57076c9a6a7fef4773dc039f3a0286c8bc962fff
+)
+
+build() {
+ cd "pscript-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "pscript-${pkgver}"
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}