summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBoris Momčilović2018-08-07 18:26:35 +0200
committerBoris Momčilović2018-08-07 18:26:35 +0200
commit98f92d005c7a941c3c786570373d03a16f77fe50 (patch)
tree54708ff5428ab9a173cfa5718ad3a58028819232
downloadaur-98f92d005c7a941c3c786570373d03a16f77fe50.tar.gz
rename package
-rw-r--r--.SRCINFO24
-rw-r--r--Imports-are-absolute-by-default-in-Python3.patch26
-rw-r--r--PKGBUILD55
-rw-r--r--pssh-read-stdin-as-bytes-in-Python-3.patch16
-rw-r--r--pssh-typeerror-str-does-not-support-the-buffer-interface.patch5
-rw-r--r--pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch6
-rw-r--r--python-pssh.changelog32
7 files changed, 164 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8d987d4ca79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = pssh
+ pkgdesc = Parallel versions of the openssh tools ssh, scp, rsync, nuke, slurp
+ pkgver = 2.3.1
+ pkgrel = 9
+ url = http://code.google.com/p/parallel-ssh/
+ changelog = python-pssh.changelog
+ arch = any
+ license = BSD
+ makedepends = patch
+ depends = openssh
+ depends = python
+ source = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/parallel-ssh/pssh-2.3.1.tar.gz
+ source = Imports-are-absolute-by-default-in-Python3.patch
+ source = pssh-typeerror-str-does-not-support-the-buffer-interface.patch
+ source = pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
+ source = pssh-read-stdin-as-bytes-in-Python-3.patch
+ sha256sums = 539f8d8363b722712310f3296f189d1ae8c690898eca93627fc89a9cb311f6b4
+ sha256sums = 12257c60e7db3d152f0b3307d0cd0263a95bddfc856aa570908a0491a1a03c56
+ sha256sums = 6b4574810b09f4ca855b81a036643aa27613ea69e1cd92755b9b9f155985d332
+ sha256sums = 40b01fd5c2aa59542a5d1bf65a41b861733f71305a9799c1d1ca6661f228a891
+ sha256sums = 47c1af738d4ba252e9f35c5633da91bae2a2919a7b6b2bf425ee1f090d61c7fe
+
+pkgname = python-pssh
+
diff --git a/Imports-are-absolute-by-default-in-Python3.patch b/Imports-are-absolute-by-default-in-Python3.patch
new file mode 100644
index 000000000000..e59fc0a7a641
--- /dev/null
+++ b/Imports-are-absolute-by-default-in-Python3.patch
@@ -0,0 +1,26 @@
+From 8afbefc445059be55dfd20785ee81e4533ae3af1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Rogut=C4=97s=20Sparnuotos?= <rogutes@googlemail.com>
+Date: Sun, 26 Feb 2012 11:05:48 +0200
+Subject: [PATCH] Imports are absolute by default in Python3.
+
+---
+ psshlib/cli.py | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/psshlib/cli.py b/psshlib/cli.py
+index c14b309..c342cde 100644
+--- a/psshlib/cli.py
++++ b/psshlib/cli.py
+@@ -6,7 +6,8 @@ import os
+ import shlex
+ import sys
+ import textwrap
+-import version
++
++from psshlib import version
+
+ _DEFAULT_PARALLELISM = 32
+ _DEFAULT_TIMEOUT = 0 # "infinity" by default
+--
+1.7.9.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4261e6de4cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer:
+# Contributor: Jaroslav Lichtblau <svetlemodry@archlinux.org>
+# Contributor: Elis Hughes <elishughes@googlemail.com>
+
+pkgbase=pssh
+pkgname=python-pssh
+pkgver=2.3.1
+pkgrel=9
+pkgdesc="Parallel versions of the openssh tools ssh, scp, rsync, nuke, slurp"
+arch=('any')
+url="http://code.google.com/p/parallel-ssh/"
+license=('BSD')
+depends=('openssh' 'python')
+makedepends=('patch')
+changelog=$pkgname.changelog
+source=(https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/parallel-ssh/$pkgbase-$pkgver.tar.gz
+ Imports-are-absolute-by-default-in-Python3.patch
+ pssh-typeerror-str-does-not-support-the-buffer-interface.patch
+ pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
+ pssh-read-stdin-as-bytes-in-Python-3.patch)
+sha256sums=('539f8d8363b722712310f3296f189d1ae8c690898eca93627fc89a9cb311f6b4'
+ '12257c60e7db3d152f0b3307d0cd0263a95bddfc856aa570908a0491a1a03c56'
+ '6b4574810b09f4ca855b81a036643aa27613ea69e1cd92755b9b9f155985d332'
+ '40b01fd5c2aa59542a5d1bf65a41b861733f71305a9799c1d1ca6661f228a891'
+ '47c1af738d4ba252e9f35c5633da91bae2a2919a7b6b2bf425ee1f090d61c7fe')
+
+prepare() {
+ cd "${srcdir}"/$pkgbase-$pkgver
+
+# fix FS#28626 (merged upstream)
+ patch -Np1 -i ../Imports-are-absolute-by-default-in-Python3.patch
+# fix FS#41255
+ patch -Np0 -i ../pssh-typeerror-str-does-not-support-the-buffer-interface.patch
+# fix FS#46571
+ patch -Np0 -i ../pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
+# fix FS#5153
+ patch -Np1 -i ../pssh-read-stdin-as-bytes-in-Python-3.patch
+}
+
+package() {
+ cd "${srcdir}"/$pkgbase-$pkgver
+
+ python setup.py install --root "${pkgdir}"
+
+# fix manpages
+ install -d "${pkgdir}"/usr/share
+ mv "${pkgdir}"/usr/man "${pkgdir}"/usr/share
+
+# fix putty pscp file conflict
+ mv "${pkgdir}"/usr/bin/pscp "${pkgdir}"/usr/bin/psshscp
+ mv "${pkgdir}"/usr/share/man/man1/pscp.1 "${pkgdir}"/usr/share/man/man1/psshscp.1
+
+# license
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/$pkgname/COPYING
+}
diff --git a/pssh-read-stdin-as-bytes-in-Python-3.patch b/pssh-read-stdin-as-bytes-in-Python-3.patch
new file mode 100644
index 000000000000..c64d77461cb2
--- /dev/null
+++ b/pssh-read-stdin-as-bytes-in-Python-3.patch
@@ -0,0 +1,16 @@
+diff --git a/bin/pssh b/bin/pssh
+index 860bad2..5fe726d 100755
+--- a/bin/pssh
++++ b/bin/pssh
+@@ -65,7 +65,10 @@ def do_pssh(hosts, cmdline, opts):
+ if opts.errdir and not os.path.exists(opts.errdir):
+ os.makedirs(opts.errdir)
+ if opts.send_input:
+- stdin = sys.stdin.read()
++ if hasattr(sys.stdin, 'buffer'):
++ stdin = sys.stdin.buffer.read()
++ else:
++ stdin = sys.stdin.read()
+ else:
+ stdin = None
+ manager = Manager(opts)
diff --git a/pssh-typeerror-str-does-not-support-the-buffer-interface.patch b/pssh-typeerror-str-does-not-support-the-buffer-interface.patch
new file mode 100644
index 000000000000..9fa81173ebbc
--- /dev/null
+++ b/pssh-typeerror-str-does-not-support-the-buffer-interface.patch
@@ -0,0 +1,5 @@
+--- psshlib/askpass_server.py.orig 2012-02-02 17:13:09.000000000 +0100
++++ psshlib/askpass_server.py 2016-01-17 11:43:37.006779012 +0100
+@@ -72 +72 @@
+- bytes_written = conn.send(buffer)
++ bytes_written = conn.send(buffer.encode())
diff --git a/pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch b/pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
new file mode 100644
index 000000000000..e1fca28b5488
--- /dev/null
+++ b/pssh-valueerror-the-fd-4-must-be-in-non-blocking-mode.patch
@@ -0,0 +1,6 @@
+--- psshlib/manager.py.orig 2012-02-02 17:13:09.000000000 +0100
++++ psshlib/manager.py 2016-01-17 11:52:13.764088460 +0100
+@@ -4,0 +5 @@
++import fcntl
+@@ -211,0 +213 @@
++ fcntl.fcntl(wakeup_writefd, fcntl.F_SETFL, os.O_NONBLOCK)
diff --git a/python-pssh.changelog b/python-pssh.changelog
new file mode 100644
index 000000000000..9acedb4c2691
--- /dev/null
+++ b/python-pssh.changelog
@@ -0,0 +1,32 @@
+2016-11-21 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * pssh 2.3.1-8 FS#51533 and pssh dropped from [community]
+
+2016-01-17 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * pssh 2.3.1-7 FS#46571 and FS#41255 fixes
+
+2015-09-19 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * pssh 2.3.1-6 python 3.5 rebuild
+
+2014-03-17 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * pssh 2.3.1-5 python 3.4 rebuild
+
+2012-02-21 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * pssh 2.3.1-1
+
+2011-05-08 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * pssh 2.2.2-4
+ * FS#23686 and FS#24032 fixed
+
+2011-03-09 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * Update to major release 2.2.2
+
+2010-03-04 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * Update to major release 2.1.1
+
+2010-02-27 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * Update to major release 2.1
+ * Changed to 'any' architecture
+
+2009-12-26 Jaroslav Lichtblau <svetlemodry@archlinux.org>
+ * Package moved to [community]
+ * version 2.0 - 18 votes in AUR