summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2018-04-04 12:24:08 +0200
committerSebastiaan Lokhorst2018-04-04 14:04:41 +0200
commitd7c75a682823c489083e4554c76047cee689cd75 (patch)
tree03eb0f1fc2c4f80562267ce8ff53c3dc2982afc2
downloadaur-d7c75a682823c489083e4554c76047cee689cd75.tar.gz
Initial commit, based on python2-psycogreen package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dcd801b57b53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-psycogreen
+ pkgdesc = psycopg2 integration with coroutine libraries
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://bitbucket.org/dvarrazzo/psycogreen
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.python.org/packages/source/p/psycogreen/psycogreen-1.0.tar.gz
+ md5sums = 7a32d8f5abdb4ce17ac512f8c8a698a9
+
+pkgname = python-psycogreen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8b5e6d2835c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Sebastiaan Lokhorst <sebastiaanlokhorst@gmail.com>
+# Contributor: Bidossessi Sodonon
+
+pkgname=python-psycogreen
+_pkgname=psycogreen
+pkgver=1.0
+pkgrel=1
+pkgdesc="psycopg2 integration with coroutine libraries"
+url=https://bitbucket.org/dvarrazzo/psycogreen
+arch=('any')
+license=('BSD')
+depends=('python')
+makedepends=('python-setuptools')
+
+source=("https://pypi.python.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('7a32d8f5abdb4ce17ac512f8c8a698a9')
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python setup.py install --root="${pkgdir}"
+}