summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenzo Gaifas2023-07-25 16:45:04 +0200
committerLorenzo Gaifas2023-07-25 16:45:04 +0200
commitcc4f30542884e746a970f3eaada0b47238f3ea4c (patch)
tree15bef45255a44a7acee5a4736fa2cc1d8c0b2d36
parentd4c878f9e7d87a8e09435c554bf8e1ffa7ce2189 (diff)
downloadaur-cc4f30542884e746a970f3eaada0b47238f3ea4c.tar.gz
v0.9.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85aaa2ee8700..59f351a3372f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = python-psygnal
pkgdesc = Fast python callback/event system modeled after Qt Signals
- pkgver = 0.7.0
+ pkgver = 0.9.1
pkgrel = 1
url = https://github.com/pyapp-kit/psygnal
arch = any
license = BSD
makedepends = python-build
makedepends = python-hatch-vcs
+ makedepends = python-hatchling
makedepends = python-installer
depends = python
depends = python-mypy_extensions
depends = python-typing_extensions
- provides = python-psygnal
- source = https://files.pythonhosted.org/packages/source/p/psygnal/psygnal-0.7.0.tar.gz
- sha256sums = 0963f77508126d35dcf7ce3933d0fde5b8e01230360bcf0ce1306eb40eb32e28
+ source = https://files.pythonhosted.org/packages/source/p/psygnal/psygnal-0.9.1.tar.gz
+ sha256sums = a42cd3e55c474673cc8f61e7cdb40fb647ca94868a1d262bf4b6d6aa2fc8bf27
pkgname = python-psygnal
diff --git a/PKGBUILD b/PKGBUILD
index 56572160bd23..3791502e831a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name='psygnal'
_author='pyapp-kit'
pkgname="python-${_name}"
-pkgver=0.7.0
+pkgver=0.9.1
pkgrel=1
pkgdesc='Fast python callback/event system modeled after Qt Signals'
arch=('any')
@@ -12,6 +12,7 @@ license=('BSD')
makedepends=(
'python-build'
'python-hatch-vcs'
+ 'python-hatchling'
'python-installer'
)
depends=(
@@ -19,9 +20,8 @@ depends=(
'python-mypy_extensions'
'python-typing_extensions'
)
-source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('0963f77508126d35dcf7ce3933d0fde5b8e01230360bcf0ce1306eb40eb32e28')
-provides=("python-${_name}")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('a42cd3e55c474673cc8f61e7cdb40fb647ca94868a1d262bf4b6d6aa2fc8bf27')
build() {
cd "${srcdir}/${_name}-${pkgver}"