summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sampson2015-06-21 20:18:39 +1000
committerMike Sampson2015-06-21 20:18:39 +1000
commit76e46996a1d11cf83136ea21c77948f1751b0444 (patch)
tree687278915da234a1ed84e76daf66c16c69ca7890
downloadaur-76e46996a1d11cf83136ea21c77948f1751b0444.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD30
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..421f5f534377
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-ptt
+ pkgdesc = Includes a Twitter API, command-line tool, and IRC bot.
+ pkgver = 1.10.0
+ pkgrel = 1
+ url = http://mike.verdone.ca/twitter/
+ arch = any
+ license = MIT
+ depends = python2
+ depends = python2-distribute
+ optdepends = python-irclib: ircbot support
+ options = !emptydirs
+ source = http://pypi.python.org/packages/source/t/twitter/twitter-1.10.0.tar.gz
+ source = LICENSE
+ md5sums = 30d6de298affb11dcf56f96db3d9b36a
+ md5sums = a5da3e25967f8405eb578fa3ab7f4098
+
+pkgname = python-ptt
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..165dc26be1fc
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+Copyright (c) 2008 Mike Verdone
+
+Permission is hereby granted, free of charge, to any person
+obtaining a copy of this software and associated documentation
+files (the "Software"), to deal in the Software without
+restriction, including without limitation the rights to use,
+copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8390da5d930d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mike Sampson <mike at sambodata dot com>
+
+pkgname=python-ptt
+pkgver=1.10.0
+pkgrel=1
+pkgdesc="Includes a Twitter API, command-line tool, and IRC bot."
+arch=(any)
+url="http://mike.verdone.ca/twitter/"
+source=("http://pypi.python.org/packages/source/t/twitter/twitter-$pkgver.tar.gz"
+ "LICENSE")
+md5sums=('30d6de298affb11dcf56f96db3d9b36a'
+ 'a5da3e25967f8405eb578fa3ab7f4098')
+license=('MIT')
+depends=('python2' 'python2-distribute')
+optdepends=('python-irclib: ircbot support')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+
+build() {
+ cd $srcdir/twitter-$pkgver
+ python2 setup.py install --root=$pkgdir/ --optimize=1
+
+ install -D -m644 $srcdir/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
+