summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A.2024-03-03 15:28:47 +0100
committerPhilipp A.2024-03-03 15:28:47 +0100
commit7f6818662301bed3fa03213ebb1e00db3c4dbecb (patch)
treed5080612c48c99ecc07bcc3ad26f82a874ed1b35
parente02efa940256cf7923fd9a40d449d410d946bcc5 (diff)
downloadaur-7f6818662301bed3fa03213ebb1e00db3c4dbecb.tar.gz
modernized build
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4df1acf1e8ac..62883555f236 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,12 @@
pkgbase = python-pubchempy
pkgdesc = A simple Python wrapper around the PubChem PUG REST API.
pkgver = 1.0.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mcs07/PubChemPy
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
depends = python
depends = python-alembic
@@ -14,4 +16,3 @@ pkgbase = python-pubchempy
sha256sums = 24e9dc2fc90ab153b2764bf805e510b1410700884faf0510a9e7cf0d61d8ed0e
pkgname = python-pubchempy
-
diff --git a/.gitignore b/.gitignore
index c5d85b20091f..1af183648070 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
/pkg/
/*.pkg.*
/*.tar.gz
+/*.log
diff --git a/PKGBUILD b/PKGBUILD
index c05973c360a7..44eabd4c7e24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,23 @@
_name=PubChemPy
pkgname=python-pubchempy
pkgver=1.0.4
-pkgrel=1
+pkgrel=2
pkgdesc='A simple Python wrapper around the PubChem PUG REST API.'
arch=(any)
url="https://github.com/mcs07/$_name"
license=(MIT)
depends=(python python-alembic python-sqlalchemy)
optdepends=(python-pandas)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-wheel python-setuptools)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name//-/_}/${_name//-/_}-$pkgver.tar.gz")
sha256sums=('24e9dc2fc90ab153b2764bf805e510b1410700884faf0510a9e7cf0d61d8ed0e')
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/${_name//-/_}-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}