summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2020-07-21 09:48:56 +0200
committerPhilipp A2020-07-21 09:48:56 +0200
commite02efa940256cf7923fd9a40d449d410d946bcc5 (patch)
tree33784ee98b3c4e5960750cc4854f7ebedd9d1927
downloadaur-e02efa940256cf7923fd9a40d449d410d946bcc5.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4df1acf1e8ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pubchempy
+ pkgdesc = A simple Python wrapper around the PubChem PUG REST API.
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/mcs07/PubChemPy
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-alembic
+ depends = python-sqlalchemy
+ optdepends = python-pandas
+ source = https://files.pythonhosted.org/packages/source/P/PubChemPy/PubChemPy-1.0.4.tar.gz
+ sha256sums = 24e9dc2fc90ab153b2764bf805e510b1410700884faf0510a9e7cf0d61d8ed0e
+
+pkgname = python-pubchempy
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c5d85b20091f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.pkg.*
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c05973c360a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=PubChemPy
+pkgname=python-pubchempy
+pkgver=1.0.4
+pkgrel=1
+pkgdesc='A simple Python wrapper around the PubChem PUG REST API.'
+arch=(any)
+url="https://github.com/mcs07/$_name"
+license=(MIT)
+depends=(python python-alembic python-sqlalchemy)
+optdepends=(python-pandas)
+makedepends=(python-setuptools)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name//-/_}/${_name//-/_}-$pkgver.tar.gz")
+sha256sums=('24e9dc2fc90ab153b2764bf805e510b1410700884faf0510a9e7cf0d61d8ed0e')
+
+package() {
+ cd "$srcdir/${_name//-/_}-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}