summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2015-06-13 10:51:19 +0200
committerSébastien Leduc2015-06-13 10:51:19 +0200
commit1cbc69f23d56edc0ba6b783a3f95cf1f2798cd32 (patch)
treebd0726238d972221e68a1c0f05422c7a0c2508a2
downloadaur-1cbc69f23d56edc0ba6b783a3f95cf1f2798cd32.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c1de3830ca1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pubsub
+ pkgdesc = Python Publish-Subscribe Package
+ pkgver = 3.3.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/PyPubSub
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = https://downloads.sf.net/project/pubsub/pubsub/3.3.0/PyPubSub-3.3.0.zip
+ sha256sums = 05e301917a8489f4fdf71bf5a717526a44c4f908e93809df366accec2886a84b
+
+pkgname = python-pubsub
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8251aba3ee8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_project=pubsub
+_pkgname=PyPubSub
+pkgname=python-$_project
+pkgver=3.3.0
+pkgrel=1
+pkgdesc="Python Publish-Subscribe Package"
+arch=("any")
+license=("BSD")
+url="https://pypi.python.org/pypi/PyPubSub"
+depends=("python")
+makedepends=("python-setuptools")
+source=("https://downloads.sf.net/project/$_project/$_project/$pkgver/$_pkgname-$pkgver.zip")
+sha256sums=("05e301917a8489f4fdf71bf5a717526a44c4f908e93809df366accec2886a84b")
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+}