summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2019-12-01 16:00:14 +0100
committerspider-mario2019-12-01 16:00:14 +0100
commit906baf08d22f11ba48674c3698d350d7ea85a49e (patch)
tree98c7ab1b753002fbf96f5ac767af9607c75898ae
parent74557a59ccdd0c8359c86e6a8a79423b452040e2 (diff)
downloadaur-906baf08d22f11ba48674c3698d350d7ea85a49e.tar.gz
2.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5ebea3d41a8..0b932b16927e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Thu Aug 17 19:36:41 UTC 2017
pkgbase = python-pulp
pkgdesc = A Linear Programming modeler written in Python
- pkgver = 1.6.8
- pkgrel = 2
+ pkgver = 2.0
+ pkgrel = 1
url = https://github.com/coin-or/pulp
arch = any
license = BSD
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/b5/87/71293d89377341551f2f331d259c0b7e7324b60ce37c597d0a42f0ebc18d/PuLP-1.6.8.tar.gz
- sha512sums = e78b33f331144f458a585fda396b5c9d1d09e25199d29fc2de39027d6cbee74dfa3325878c77ca01164102adf22ee5bb31beea5af54500c1ad917cedb2dbf783
+ source = https://files.pythonhosted.org/packages/e4/33/2882343b235326f6a1b8c6208ade294e3f4efd12d635af7e36eb27b69202/PuLP-2.0.tar.gz
+ sha512sums = 21a67e5e8b8911e472f5dd1525dc9cdccd26ad3c85b3c8070d2f69b91bc47cbb47751e72a152f0efefaafcf7c07e4d8215962f05a14cb14ce113f4399b514d52
pkgname = python-pulp
depends = python-pyparsing
diff --git a/PKGBUILD b/PKGBUILD
index aa903af8792d..85169ff1258f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
_pkgname=PuLP
pkgbase=python-pulp
pkgname=(python-pulp python2-pulp)
-pkgver=1.6.8
-pkgrel=2
+pkgver=2.0
+pkgrel=1
pkgdesc="A Linear Programming modeler written in Python"
arch=("any")
license=("BSD")
url="https://github.com/coin-or/pulp"
makedepends=('python-setuptools' 'python2-setuptools')
-source=("https://files.pythonhosted.org/packages/b5/87/71293d89377341551f2f331d259c0b7e7324b60ce37c597d0a42f0ebc18d/$_pkgname-$pkgver.tar.gz")
-sha512sums=('e78b33f331144f458a585fda396b5c9d1d09e25199d29fc2de39027d6cbee74dfa3325878c77ca01164102adf22ee5bb31beea5af54500c1ad917cedb2dbf783')
+source=("https://files.pythonhosted.org/packages/e4/33/2882343b235326f6a1b8c6208ade294e3f4efd12d635af7e36eb27b69202/$_pkgname-$pkgver.tar.gz")
+sha512sums=('21a67e5e8b8911e472f5dd1525dc9cdccd26ad3c85b3c8070d2f69b91bc47cbb47751e72a152f0efefaafcf7c07e4d8215962f05a14cb14ce113f4399b514d52')
prepare() {
for _python in python python2; do
@@ -49,6 +49,5 @@ package_python2-pulp() {
depends=('python2-pyparsing')
_package_for_python_version python2
- # Uncomment the following line if you want to install both versions at the same time:
- # rm "$pkgdir"/usr/bin/pulp{,doc}test
+ rm "$pkgdir"/usr/bin/pulptest
}