summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatteo De Carlo2018-03-08 15:24:05 +0100
committerMatteo De Carlo2018-03-08 15:24:05 +0100
commitb197e7bc7eb0319f9162e31ff4e02b11098e7c82 (patch)
tree56cbc3ad2c091338b97e13fd09e9ce390fa6e0d6
downloadaur-b197e7bc7eb0319f9162e31ff4e02b11098e7c82.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb554e1c9345
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pulse-control
+ pkgdesc = Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)
+ pkgver = 18.3.1
+ pkgrel = 1
+ url = http://github.com/mk-fg/python-pulse-control
+ arch = any
+ license = MIT
+ depends = python
+ depends = pulseaudio
+ source = https://pypi.python.org/packages/5e/5f/b5d9a3728ca062b811c337e1e7c19d12ec3f95f13a511141c43ada5def94/pulsectl-18.3.1.tar.gz#md5=43ae095362d39b270df8cf3368fd7999
+ md5sums = 43ae095362d39b270df8cf3368fd7999
+
+pkgname = python-pulse-control
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e894fc0dcfdc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: portaloffreedom
+
+_pkgsrcname=pulsectl
+pkgname=python-pulse-control
+pkgver=18.3.1
+pkgrel=1
+pkgdesc="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
+url="http://github.com/mk-fg/python-pulse-control"
+license=("MIT")
+arch=("any")
+depends=('python' 'pulseaudio')
+source=("https://pypi.python.org/packages/5e/5f/b5d9a3728ca062b811c337e1e7c19d12ec3f95f13a511141c43ada5def94/$_pkgsrcname-$pkgver.tar.gz#md5=43ae095362d39b270df8cf3368fd7999")
+md5sums=('43ae095362d39b270df8cf3368fd7999')
+
+package() {
+ cd $srcdir/${_pkgsrcname}-$pkgver
+ python3 setup.py install --root $pkgdir
+ rm -rf $pkgdir/usr/lib/python3.6/site-packages/$_pkgsrcname/tests/
+}
+
+