summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2020-06-29 23:42:11 +0100
committerWorMzy Tykashi2020-06-29 23:42:11 +0100
commit41ec6c3c1613119a819aac858a359fb821a0209a (patch)
treed6821fe45b8a0f119d3edb6b54ed922258679e22
downloadaur-41ec6c3c1613119a819aac858a359fb821a0209a.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a75b5a1a6277
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pulsectl
+ pkgdesc = high-level interface and ctypes-based bindings for PulseAudio (libpulse)
+ pkgver = 20.6.0
+ pkgrel = 1
+ url = https://github.com/mk-fg/python-pulse-control
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ source = git+https://github.com/mk-fg/python-pulse-control.git?commit=471428cd7d03356f0641fe93a8156b799d57ce02
+ md5sums = SKIP
+
+pkgname = python-pulsectl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfd2ab62611e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+pkgname=python-pulsectl
+_gitname=python-pulse-control
+pkgver=20.6.0
+pkgrel=1
+pkgdesc="high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
+arch=('any')
+url="https://github.com/mk-fg/python-pulse-control"
+license=('MIT')
+depends=('python')
+makedepends=('git' 'python-setuptools')
+# Upstream does not tag releases, check https://github.com/mk-fg/python-pulse-control/commits/master/setup.py
+# and find the latest commit that updates version in setup()
+source=(git+"https://github.com/mk-fg/python-pulse-control.git?commit=471428cd7d03356f0641fe93a8156b799d57ce02")
+md5sums=('SKIP')
+
+build() {
+ cd ${_gitname}
+ python setup.py build
+}
+
+package() {
+ cd ${_gitname}
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/COPYING
+}
+
+# vim:set ts=2 sw=2 et: