summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-03-23 08:54:44 -0600
committerMark Wagie2022-03-23 08:54:44 -0600
commit76143bce9946750e9a23a2bac0d2c7d4121b820f (patch)
tree5001ee523da4e9a4b9982e5b490db0fac1829672
parent7aa52685827004741833d875a7102abf55ea323c (diff)
downloadaur-76143bce9946750e9a23a2bac0d2c7d4121b820f.tar.gz
22.3.2
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD5
-rw-r--r--pulsectl-CHANGES.rst59
4 files changed, 67 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41ecd53b5b63..875ef23eb307 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = python-pulsectl
pkgdesc = Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)
- pkgver = 22.1.3
+ pkgver = 22.3.2
pkgrel = 1
epoch = 1
url = https://github.com/mk-fg/python-pulse-control
+ changelog = pulsectl-CHANGES.rst
arch = any
license = MIT
makedepends = python-setuptools
@@ -11,7 +12,7 @@ pkgbase = python-pulsectl
depends = libpulse
conflicts = python-pulse-control
replaces = python-pulse-control
- source = https://pypi.org/packages/source/p/pulsectl/pulsectl-22.1.3.tar.gz
- sha256sums = f28fe4b881dd2cc144d2d94f83ec60d8c59a52642a0ad3635cc4d0f8406f4858
+ source = https://pypi.org/packages/source/p/pulsectl/pulsectl-22.3.2.tar.gz
+ sha256sums = cc174e1ceebd4e6222c5b78f4f415f12e80753c9ab75ab354159b4cb5950b084
pkgname = python-pulsectl
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..5809b633657b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!pulsectl-CHANGES.rst
diff --git a/PKGBUILD b/PKGBUILD
index a1d4d749105a..8b4d310b7e62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: WorMzy Tykashi <wormzy.tykashi@gmail.com>
pkgname=python-pulsectl
_name=${pkgname#python-}
-pkgver=22.1.3
+pkgver=22.3.2
pkgrel=1
epoch=1
pkgdesc="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
@@ -13,8 +13,9 @@ depends=('python' 'libpulse')
makedepends=('python-setuptools')
conflicts=('python-pulse-control')
replaces=('python-pulse-control')
+changelog="$_name-CHANGES.rst"
source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('f28fe4b881dd2cc144d2d94f83ec60d8c59a52642a0ad3635cc4d0f8406f4858')
+sha256sums=('cc174e1ceebd4e6222c5b78f4f415f12e80753c9ab75ab354159b4cb5950b084')
build() {
cd "$_name-$pkgver"
diff --git a/pulsectl-CHANGES.rst b/pulsectl-CHANGES.rst
new file mode 100644
index 000000000000..1621fc6947b1
--- /dev/null
+++ b/pulsectl-CHANGES.rst
@@ -0,0 +1,59 @@
+=========
+ CHANGES
+=========
+
+Only (unlikely) intentional breaking changes and new/added non-trivial
+functionality is listed here, no bugfixes or commit messages.
+
+Each entry is a package version which change first appears in,
+followed by description of the change itself.
+
+Last synced/updated: 22.3.2
+
+---------------------------------------------------------------------------
+
+- 21.10.4: Add channel_list_enum to compare channel_list values with something
+ in a typo-free way, expose channel_list_raw with C enum values [#66].
+
+- 21.5.0: Fix PA_VOLUME_MAX and PA_VOLUME_UI_MAX values, both were incorrect [#53].
+
+- 21.3.4: Add timeout= option for connect() method [#48].
+
+- 21.3.1: There is now https://pypi.org/project/pulsectl-asyncio/ module [#46].
+
+ It is maintained separately, and should provide similar bindings to use with async apps.
+
+- 20.2.4: Add pulse.get_card_by_name() wrapper [#38].
+
+- 20.1.1: Add pulse.play_sample() - server-side stored sample playback [#36].
+
+ Loading is not implemented, would suggest something like libcanberra for that.
+
+- 19.9.1: Add pulse.get_peak_sample() func for getting volume peak within timespan [#33].
+
+- 18.10.5: pulse.connect() can now be used to reconnect to same server.
+
+- 17.12.2: Use pa_card_profile_info2 / profiles2 introspection API [#19].
+
+ Only adds one "available" property to PulseCardProfileInfo.
+ Requires pulseaudio/libpulse 5.0+.
+
+- 17.9.3: Add wrappers for Pulse.get_sink_by_name / Pulse.get_source_by_name [#17].
+
+ More efficient alternative for sink_input_list / source_output_list filtering.
+
+- 17.6.0: Add PulseCardInfo.port_list [#15].
+
+ These ports are different from sink/source ports in that they have proplist,
+ card profiles and some other parameters associated with them, implemented as
+ PulseCardPortInfo instances.
+
+- 17.1.3: Add wrappers for card profiles [#14].
+
+ More specifically - PulseCardProfileInfo objects and PulseCardInfo
+ "profile_list" and "profile_active" attributes.
+
+ ``pulse.card_profile_set(card, profile)`` can be used to set active profile
+ (either by name or PulseCardProfileInfo object).
+
+- 16.11.0: This changelog file was started, thanks to the idea from #12.