summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-05-05 18:10:37 -0600
committerMark Wagie2023-05-05 18:10:37 -0600
commitbebaecd9082faf482ba880f608d93009b42fb493 (patch)
treeba710e2c2d44405cfb3e30fa91a55d4b5691e025
parent07b32126b56efb38158aa67e477bd45d376e55d3 (diff)
downloadaur-bebaecd9082faf482ba880f608d93009b42fb493.tar.gz
23.5.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
-rw-r--r--pulsectl-CHANGES.rst59
3 files changed, 7 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a55b2790e593..a54c8091a729 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = python-pulsectl
pkgdesc = Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)
- pkgver = 22.3.2
- pkgrel = 2
+ pkgver = 23.5.0
+ pkgrel = 1
epoch = 1
url = https://github.com/mk-fg/python-pulse-control
- changelog = pulsectl-CHANGES.rst
arch = any
license = MIT
makedepends = python-build
@@ -15,7 +14,7 @@ pkgbase = python-pulsectl
depends = libpulse
conflicts = python-pulse-control
replaces = python-pulse-control
- source = https://files.pythonhosted.org/packages/source/p/pulsectl/pulsectl-22.3.2.tar.gz
- sha256sums = cc174e1ceebd4e6222c5b78f4f415f12e80753c9ab75ab354159b4cb5950b084
+ source = https://files.pythonhosted.org/packages/source/p/pulsectl/pulsectl-23.5.0.tar.gz
+ sha256sums = 8b8a487f1a63b4108e0fc84eab9177c96fb14aafa1a550f52a40c5f7fce99672
pkgname = python-pulsectl
diff --git a/PKGBUILD b/PKGBUILD
index e0ec58c91363..eb4162f4bc7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: WorMzy Tykashi <wormzy.tykashi@gmail.com>
pkgname=python-pulsectl
_name=${pkgname#python-}
-pkgver=22.3.2
-pkgrel=2
+pkgver=23.5.0
+pkgrel=1
epoch=1
pkgdesc="Python high-level interface and ctypes-based bindings for PulseAudio (libpulse)"
arch=('any')
@@ -13,9 +13,8 @@ depends=('python' 'libpulse')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
conflicts=('python-pulse-control')
replaces=('python-pulse-control')
-changelog="$_name-CHANGES.rst"
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('cc174e1ceebd4e6222c5b78f4f415f12e80753c9ab75ab354159b4cb5950b084')
+sha256sums=('8b8a487f1a63b4108e0fc84eab9177c96fb14aafa1a550f52a40c5f7fce99672')
build() {
cd "$_name-$pkgver"
diff --git a/pulsectl-CHANGES.rst b/pulsectl-CHANGES.rst
deleted file mode 100644
index 1621fc6947b1..000000000000
--- a/pulsectl-CHANGES.rst
+++ /dev/null
@@ -1,59 +0,0 @@
-=========
- CHANGES
-=========
-
-Only (unlikely) intentional breaking changes and new/added non-trivial
-functionality is listed here, no bugfixes or commit messages.
-
-Each entry is a package version which change first appears in,
-followed by description of the change itself.
-
-Last synced/updated: 22.3.2
-
----------------------------------------------------------------------------
-
-- 21.10.4: Add channel_list_enum to compare channel_list values with something
- in a typo-free way, expose channel_list_raw with C enum values [#66].
-
-- 21.5.0: Fix PA_VOLUME_MAX and PA_VOLUME_UI_MAX values, both were incorrect [#53].
-
-- 21.3.4: Add timeout= option for connect() method [#48].
-
-- 21.3.1: There is now https://pypi.org/project/pulsectl-asyncio/ module [#46].
-
- It is maintained separately, and should provide similar bindings to use with async apps.
-
-- 20.2.4: Add pulse.get_card_by_name() wrapper [#38].
-
-- 20.1.1: Add pulse.play_sample() - server-side stored sample playback [#36].
-
- Loading is not implemented, would suggest something like libcanberra for that.
-
-- 19.9.1: Add pulse.get_peak_sample() func for getting volume peak within timespan [#33].
-
-- 18.10.5: pulse.connect() can now be used to reconnect to same server.
-
-- 17.12.2: Use pa_card_profile_info2 / profiles2 introspection API [#19].
-
- Only adds one "available" property to PulseCardProfileInfo.
- Requires pulseaudio/libpulse 5.0+.
-
-- 17.9.3: Add wrappers for Pulse.get_sink_by_name / Pulse.get_source_by_name [#17].
-
- More efficient alternative for sink_input_list / source_output_list filtering.
-
-- 17.6.0: Add PulseCardInfo.port_list [#15].
-
- These ports are different from sink/source ports in that they have proplist,
- card profiles and some other parameters associated with them, implemented as
- PulseCardPortInfo instances.
-
-- 17.1.3: Add wrappers for card profiles [#14].
-
- More specifically - PulseCardProfileInfo objects and PulseCardInfo
- "profile_list" and "profile_active" attributes.
-
- ``pulse.card_profile_set(card, profile)`` can be used to set active profile
- (either by name or PulseCardProfileInfo object).
-
-- 16.11.0: This changelog file was started, thanks to the idea from #12.