summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemmitt Sigler2021-07-19 17:26:53 -0400
committerClemmitt Sigler2021-07-19 17:26:53 -0400
commit798954a1a18fa095932517bcc49a97988eaf04ef (patch)
treefcebd54473f41d300440c0dcc451d64ae0bb751b
downloadaur-798954a1a18fa095932517bcc49a97988eaf04ef.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07229c709b08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pulsectl-asyncio-git
+ pkgdesc = Asyncio frontend for pulsectl, a Python bindings library for PulseAudio (libpulse) -- git version
+ pkgver = 20210613
+ pkgrel = 1
+ url = https://github.com/mhthies/pulsectl-asyncio
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python>=3.6
+ depends = python-pulsectl>=1:21.5.18
+ provides = python-pulsectl-asyncio
+ conflicts = python-pulsectl-asyncio
+ source = git+https://github.com/mhthies/pulsectl-asyncio.git
+ md5sums = SKIP
+
+pkgname = python-pulsectl-asyncio-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b545928cbcf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Clemmitt Sigler <cmsigler (dot) online (at) gmail (dot) com>
+
+pkgname=python-pulsectl-asyncio-git
+_gitname=pulsectl-asyncio
+pkgver=20210613
+pkgrel=1
+pkgdesc="Asyncio frontend for pulsectl, a Python bindings library for PulseAudio (libpulse) -- git version"
+arch=('x86_64')
+url="https://github.com/mhthies/pulsectl-asyncio"
+license=('MIT')
+depends=('python>=3.6' 'python-pulsectl>=1:21.5.18')
+makedepends=('git' 'python-setuptools')
+provides=('python-pulsectl-asyncio')
+conflicts=('python-pulsectl-asyncio')
+source=('git+https://github.com/mhthies/pulsectl-asyncio.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git log -1 --format="%cd" --date=short | sed 's|-||g'
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 ft=sh et: