summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVxlerieUwU2023-06-10 16:48:35 +0200
committerVxlerieUwU2023-06-10 16:48:35 +0200
commit15eeadb801153ee65c28c803b0fa6618fc3324cf (patch)
treee109af1fa717be46b442e4f3fb2333a6beb4469f
parent67395de079aac56e7fe20d195194facf57f19ca7 (diff)
downloadaur-15eeadb801153ee65c28c803b0fa6618fc3324cf.tar.gz
version 2.3.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbbd835ccbda..c5d593d19b95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = python-pure-protobuf
pkgdesc = Python implementation of Protocol Buffers data types with dataclasses support.
- pkgver = 2.1.1
+ pkgver = 2.3.0
pkgrel = 1
url = https://github.com/eigenein/protobuf
arch = any
license = MIT
makedepends = git
makedepends = python-setuptools
+ makedepends = python-hatchling
+ makedepends = python-hatch-vcs
depends = python
provides = python-pure-protobuf
- source = protobuf-2.1.1.tar.gz::https://www.github.com/eigenein/protobuf/archive/2.1.1.tar.gz
- sha256sums = 91854ece115b9fdc36facf73ac96945de32d71cb279fe116f186c1c670e1b61e
+ source = git+https://www.github.com/eigenein/protobuf#tag=2.3.0
+ sha256sums = SKIP
pkgname = python-pure-protobuf
diff --git a/PKGBUILD b/PKGBUILD
index 575a02991e72..98a38bd71638 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-pure-protobuf
_author=eigenein
_gitname=protobuf
-pkgver=2.1.1
+pkgver=2.3.0
pkgrel=1
pkgdesc='Python implementation of Protocol Buffers data types with dataclasses support.'
url='https://github.com/eigenein/protobuf'
@@ -13,13 +13,20 @@ depends=('python')
makedepends=(
git
python-setuptools
+ python-hatchling
+ python-hatch-vcs
)
provides=('python-pure-protobuf')
-source=("$_gitname-$pkgver.tar.gz::https://www.github.com/$_author/$_gitname/archive/$pkgver.tar.gz")
-sha256sums=('91854ece115b9fdc36facf73ac96945de32d71cb279fe116f186c1c670e1b61e')
+source=("git+https://www.github.com/$_author/$_gitname#tag=$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/$_gitname"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$_gitname-$pkgver"
- python setup.py install --root=$pkgdir
+ cd "$srcdir/$_gitname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}