summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHideaki Takahashi2015-06-20 14:35:32 -0400
committerHideaki Takahashi2015-06-20 14:35:32 -0400
commit1c99f262d1209e113048b60c38a7ca32d30a1de6 (patch)
tree8498b55d42b22b9b57d7c363f7ea82facfc19900
downloadaur-1c99f262d1209e113048b60c38a7ca32d30a1de6.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25f0600b85e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pushbullet.py
+ pkgdesc = A simple python client for pushbullet.com.
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://github.com/randomchars/pushbullet.py
+ arch = any
+ license = MIT
+ depends = python-requests
+ depends = python-magic
+ depends = python-websocket-client
+ source = https://pypi.python.org/packages/source/p/pushbullet.py/pushbullet.py-0.8.1.tar.gz
+ md5sums = 1e8eccd95062df199830d92a29c57bdf
+
+pkgname = python-pushbullet.py
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c26654e0356c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Hideaki Takahashi <mymelo+aur@gmail.com>
+python=python
+
+_libname=pushbullet.py
+pkgname=python-$_libname
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="A simple python client for pushbullet.com."
+depends=('python-requests' 'python-magic' 'python-websocket-client')
+arch=('any')
+source=(https://pypi.python.org/packages/source/p/pushbullet.py/${_libname}-${pkgver}.tar.gz)
+md5sums=('1e8eccd95062df199830d92a29c57bdf')
+
+url="https://github.com/randomchars/pushbullet.py"
+license="MIT"
+
+build() {
+ cd $srcdir/$_libname-$pkgver
+
+ sed -i 's/==/>=/g' requirements.txt
+
+ $python setup.py build || return 1
+}
+
+package() {
+ cd $srcdir/$_libname-$pkgver
+
+ $python setup.py install --root=$pkgdir
+
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}