summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTarn Burton2017-08-19 09:51:59 -0400
committerTarn Burton2017-08-19 09:51:59 -0400
commit54f5fb4e1a210389d7bb0556005e480249051dfc (patch)
tree1d95f7d99616bcf5214355e2e5568947c29d1c42
parent22b0bf38497dd03d1dd29cd2ff6fd5189a92bcaf (diff)
downloadaur-54f5fb4e1a210389d7bb0556005e480249051dfc.tar.gz
Update to v0.25.0
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa14a938dab3..55cfcc014143 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-pweave
pkgdesc = A scientific report generator and literate programming tool for Python.
- pkgver = 0.23
+ pkgver = 0.25
pkgrel = 1
url = http://mpastell.com/pweave/
arch = any
- license = GPL
+ license = BSD
+ makedepends = python-setuptools
depends = python
- options = !emptydirs
- source = http://pypi.python.org/packages/source/P/Pweave/Pweave-0.23.tar.gz
- md5sums = 0bc76bd90f3a0380f3c8975e10544815
+ source = https://pypi.python.org/packages/f6/2f/e9735b04747ae5ef29d64e0b215fb0e11f1c89826097ac17342efebbbb84/Pweave-0.25.tar.gz
+ sha256sums = 1c0f6921196646243eb7ff9eee742305909be2bc7a5eeeb06a7d1f66cc9758c7
pkgname = python-pweave
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c230193ac7b8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index b43fb0722e59..b3e652bdffae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,22 @@
-# Maintainer: Milo Mirate <mmirate@gmx.com>
+# Maintainer: Tarn Burton <twburton at gmail dot com>
+# Contributor: Milo Mirate <mmirate at gmx.com>
+
_pkgname=Pweave
pkgname=python-pweave
-pkgver=0.23
+pkgver=0.25
pkgrel=1
pkgdesc="A scientific report generator and literate programming tool for Python."
arch=(any)
url="http://mpastell.com/pweave/"
-license=('GPL')
-groups=()
+license=('BSD')
depends=('python')
-makedepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=(!emptydirs)
-install=
-source=("http://pypi.python.org/packages/source/P/$_pkgname/$_pkgname-$pkgver.tar.gz")
-md5sums=('0bc76bd90f3a0380f3c8975e10544815')
+makedepends=('python-setuptools')
+source=("https://pypi.python.org/packages/f6/2f/e9735b04747ae5ef29d64e0b215fb0e11f1c89826097ac17342efebbbb84/$_pkgname-$pkgver.tar.gz")
+sha256sums=('1c0f6921196646243eb7ff9eee742305909be2bc7a5eeeb06a7d1f66cc9758c7')
package() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$_pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
rename P p "$pkgdir/usr/bin/P"*
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-
-# vim:set ts=2 sw=2 et: