summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-06-10 11:33:40 -0500
committerCarlos Aznarán Laos2023-06-10 11:33:40 -0500
commitdd461f7f82f9e0d563eef4977a0faed343df43e5 (patch)
tree8314db089e81ffb7e8cd00c33c769f9ca8b78d25
parent80d9a147a7a079555e9b8ff3b400965f0d62dc29 (diff)
downloadaur-dd461f7f82f9e0d563eef4977a0faed343df43e5.tar.gz
Python 3.11 rebuild
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 930c10bc9976..4af214a8a080 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-py-eddy-tracker-sample
pkgdesc = Py-Eddy-Tracker samples
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/AntSimi/py-eddy-tracker-sample
arch = any
license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
source = py-eddy-tracker-sample-0.1.0.tar.gz::https://github.com/AntSimi/py-eddy-tracker-sample/archive/v0.1.0.tar.gz
sha512sums = f48f80f869705ec426c033738b5b41c1e88a39c037159c62a9952d320a658acbeb6d5ae208f17e63ab5835636dcb8655511aa99e3bf1b3d0afddbf2228034440
diff --git a/PKGBUILD b/PKGBUILD
index d54599aded4e..e2079d7a87fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,22 @@ _base=py-eddy-tracker-sample
pkgname=python-${_base}
pkgdesc="Py-Eddy-Tracker samples"
pkgver=0.1.0
-pkgrel=1
+pkgrel=2
arch=(any)
url="https://github.com/AntSimi/${_base}"
license=(GPL3)
depends=(python)
-makedepends=(python-setuptools)
+makedepends=(python-build python-installer python-setuptools python-wheel)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('f48f80f869705ec426c033738b5b41c1e88a39c037159c62a9952d320a658acbeb6d5ae208f17e63ab5835636dcb8655511aa99e3bf1b3d0afddbf2228034440')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
}