summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-11-29 12:08:44 -0500
committerCarlos Aznarán Laos2022-11-29 12:08:44 -0500
commit179f75401744d3a583a13e2cbebe25de1f0d111d (patch)
tree1db48e0e72c3f58c8053aec24b9a493eda938799
parent61af4037fac9ec983e59e397eb3240e1a596f6f4 (diff)
downloadaur-179f75401744d3a583a13e2cbebe25de1f0d111d.tar.gz
Bump version to 0.25.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 30 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc28fc92af60..2e1a5ced8f3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,26 @@
pkgbase = python-py-pde
pkgdesc = Python package for solving partial differential equations
- pkgver = 0.24.12
+ pkgver = 0.25.0
pkgrel = 1
url = https://github.com/zwicker-group/py-pde
arch = any
license = MIT
- makedepends = python-setuptools
- makedepends = python-versioneer
- depends = python-sympy
- depends = python-scipy
- depends = python-numba
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools-scm
+ makedepends = python-wheel
depends = python-matplotlib
+ depends = python-numba
+ depends = python-scipy
+ depends = python-sympy
depends = python-tqdm
optdepends = python-h5py: for storing data in the hierarchical file format
optdepends = python-pandas: for handling tabular data
optdepends = napari: for displaying images interactively
optdepends = python-ipywidgets: for interactive widgets
optdepends = python-numba-mpi: for njittable MPI wrapper
- source = py-pde-0.24.12.tar.gz::https://github.com/zwicker-group/py-pde/archive/0.24.12.tar.gz
- sha512sums = bde2f763f50f91692d9fe7afb499a2404d04099aa858d2ca0105f2e7ccb85510f79210e25fc67450c12ae1995a0ce53d99c6211900a4d05d6e61edc0c6a14f27
+ optdepends = python-mpi4py: for parallel processing using MPI
+ source = py-pde-0.25.0.tar.gz::https://github.com/zwicker-group/py-pde/archive/0.25.0.tar.gz
+ sha512sums = 0a25c72e1868059ad96938472de610af3c4c070980e7ecb08bc669ccd4d673fab26ebb6e51eef79edb3c5a6af0484038ba092348b2c254598d130a9374ddc379
pkgname = python-py-pde
diff --git a/PKGBUILD b/PKGBUILD
index 11c06793b6bd..007380d3c78d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,43 @@
_base=py-pde
pkgname=python-${_base}
pkgdesc="Python package for solving partial differential equations"
-pkgver=0.24.12
+pkgver=0.25.0
pkgrel=1
arch=(any)
url="https://github.com/zwicker-group/${_base}"
license=(MIT)
-depends=(python-sympy python-scipy python-numba python-matplotlib python-tqdm)
-makedepends=(python-setuptools python-versioneer)
+depends=(python-matplotlib python-numba python-scipy python-sympy python-tqdm)
+makedepends=(python-build python-installer python-setuptools-scm python-wheel)
# checkdepends=(python-pytest python-h5py python-pandas napari)
optdepends=('python-h5py: for storing data in the hierarchical file format'
'python-pandas: for handling tabular data'
'napari: for displaying images interactively'
'python-ipywidgets: for interactive widgets'
- 'python-numba-mpi: for njittable MPI wrapper')
+ 'python-numba-mpi: for njittable MPI wrapper'
+ 'python-mpi4py: for parallel processing using MPI')
source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
-sha512sums=('bde2f763f50f91692d9fe7afb499a2404d04099aa858d2ca0105f2e7ccb85510f79210e25fc67450c12ae1995a0ce53d99c6211900a4d05d6e61edc0c6a14f27')
+sha512sums=('0a25c72e1868059ad96938472de610af3c4c070980e7ecb08bc669ccd4d673fab26ebb6e51eef79edb3c5a6af0484038ba092348b2c254598d130a9374ddc379')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
# check() {
-# cd ${_base}-${pkgver}/tests
-# MPLBACKEND=Agg NUMBA_WARNINGS=1 python run_tests.py --unit # --use_mpi
+# cd ${_base}-${pkgver}/tests
+# python -m venv --system-site-packages test-env
+# test-env/bin/python -m installer dist/*.whl
+# MPLBACKEND=Agg NUMBA_WARNINGS=1 test-env/bin/python run_tests.py --unit # --use_mpi
# }
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+
+ # Symlink license file
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s "${site_packages}/${_base/-/_}-${pkgver}.dist-info/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}