summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorentriphy2022-07-02 23:28:25 -0700
committerentriphy2022-07-02 23:28:25 -0700
commit62b41fd769cfbac070cdde7da915e44cca61cfa7 (patch)
tree60cbcd36d834935968f58ec2491ca4650b22d94c
parent723c7abd0386c19809e88be609beaef1eba03006 (diff)
downloadaur-62b41fd769cfbac070cdde7da915e44cca61cfa7.tar.gz
Use standards-based install method
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c32330041bac..021186c4a14a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,13 @@
pkgbase = python-pyairtable
pkgdesc = Python client for the Airtable API
pkgver = 1.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gtalarico/pyairtable
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
depends = python-requests
diff --git a/PKGBUILD b/PKGBUILD
index 64425926d4b4..cee231c858c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,23 @@
pkgname=python-pyairtable
_pkgname=pyairtable
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python client for the Airtable API"
arch=("any")
url="https://github.com/gtalarico/$_pkgname"
license=("MIT")
options=(!emptydirs)
depends=("python" "python-requests")
-makedepends=("python-setuptools")
+makedepends=("python-build" "python-installer" "python-wheel" "python-setuptools")
source=("$url/archive/refs/tags/$pkgver.tar.gz")
sha256sums=("b31718b64cd44fd3b1275b78bc3eeb6dd8ca38b0720daac71f734183ea61a5ad")
build() {
cd "$_pkgname-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}