summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-02-06 18:18:42 -0500
committerCarlos Aznarán Laos2022-02-06 18:18:42 -0500
commit58b55d144cb9752ede03fe85248a8d398f796a5f (patch)
tree2de96d3da7e65f8bdc95b12058f092932b05f43f
parentca8cc14255ab2c8e9668f3059de39d6ed289e565 (diff)
downloadaur-58b55d144cb9752ede03fe85248a8d398f796a5f.tar.gz
Version bump to 4.2.2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3a3cd3be01d..3536a5836727 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyamg
pkgdesc = Algebraic Multigrid Solvers in Python
- pkgver = 4.2.1
+ pkgver = 4.2.2
pkgrel = 1
url = https://github.com/pyamg/pyamg
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = python-pyamg
makedepends = git
depends = python-scipy
depends = python-pytest
- source = pyamg-4.2.1::git+https://github.com/pyamg/pyamg.git?signed#commit=e013dbfbc14ff8b5816fb1622f22752557421d95
+ source = pyamg-4.2.2::git+https://github.com/pyamg/pyamg.git?signed#commit=e9f22184813dbc39ae51bba95b4b8aaa0b805818
validpgpkeys = 4DDCC34E24417C71C667DC2850BBE7E24BA62FF7
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5941396425e3..c8a26475bef2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_base=pyamg
pkgname=python-${_base}
pkgdesc="Algebraic Multigrid Solvers in Python"
-_gitcommit=e013dbfbc14ff8b5816fb1622f22752557421d95
-pkgver=4.2.1
+_gitcommit=e9f22184813dbc39ae51bba95b4b8aaa0b805818
+pkgver=4.2.2
pkgrel=1
arch=('x86_64')
url="https://github.com/${_base}/${_base}"
@@ -17,7 +17,8 @@ sha512sums=('SKIP')
# https://bbs.archlinux.org/viewtopic.php?id=249188
build() {
- cd "${_base}-${pkgver}"
+ cd ${_base}-${pkgver}
+ export PYTHONHASHSEED=0
python setup.py build
}
@@ -27,8 +28,7 @@ check() {
}
package() {
- cd "${_base}-${pkgver}"
- export PYTHONHASHSEED=0
+ cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}