summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-03-10 10:31:40 +0800
committerPumpkinCheshire2021-03-10 10:31:40 +0800
commit649e1d86dfc7e09d22f88f6fb95086600cede0e8 (patch)
tree89c2fc6a39f4747b5e4fa5a941fc217b44b59adb
downloadaur-649e1d86dfc7e09d22f88f6fb95086600cede0e8.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e8faee3f585c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pyan3
+ pkgdesc = pyan is a Python module that performs static analysis of Python code to determine a call dependency graph between functions and methods.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/Technologicat/pyan
+ arch = x86_64
+ license = GPL
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python-jinja
+ source = https://files.pythonhosted.org/packages/source/p/pyan3/pyan3-1.2.0.tar.gz
+ sha256sums = 36b49b678820e882de7271fb8a18789d57cd1e284f0314bdecd587f02c049a19
+
+pkgname = python-pyan3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d93ef22ea818
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: pumpkincheshire <sollyonzou at gmail dot com>
+
+pkgname=python-pyan3
+_name=pyan3
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='pyan is a Python module that performs static analysis of Python code to determine a call dependency graph between functions and methods.'
+arch=('x86_64')
+url='https://github.com/Technologicat/pyan'
+license=('GPL')
+depends=('python-jinja')
+makedepends=('python' 'python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('36b49b678820e882de7271fb8a18789d57cd1e284f0314bdecd587f02c049a19')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # install -Dm644 $scrdir/README* "${pkgdir}/usr/share/doc/${pkgname}/README"
+} \ No newline at end of file