summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Sorg2023-10-14 00:40:35 +0200
committerSimon Sorg2023-10-14 00:40:35 +0200
commitdfedf56736fd0dff4a4be14cc49e98b8c7da8a8c (patch)
tree7449cea224f579d26227225fc029f08432a07ca5
downloadaur-dfedf56736fd0dff4a4be14cc49e98b8c7da8a8c.tar.gz
Add pyannote core git version
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD52
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8ec98d6df2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-pyannote.core-git
+ pkgdesc = Advanced data structures for handling temporal segments with attached labels.
+ pkgver = 5.0.0.g13a43c2
+ pkgrel = 1
+ url = https://github.com/pyannote/pyannote-core
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = python-pytest
+ depends = python-sortedcontainers
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-typing_extensions
+ provides = pyannote.core
+ conflicts = pyannote.core
+ source = pyannote-core::git+https://github.com/pyannote/pyannote-core
+ md5sums = SKIP
+
+pkgname = python-pyannote.core-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bd4ddd0657f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Simon Sorg <simon.sorg@student.hpi.de>
+_dirname=pyannote-core
+_pkgname=pyannote.core
+pkgname=python-$_pkgname-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=5.0.0.g13a43c2
+pkgrel=1
+pkgdesc="Advanced data structures for handling temporal segments with attached labels."
+arch=('any')
+url="https://github.com/pyannote/pyannote-core"
+license=('MIT')
+depends=(
+ 'python-sortedcontainers'
+ 'python-numpy'
+ 'python-scipy'
+ 'python-typing_extensions'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+ 'python-pytest'
+)
+
+provides=("$_pkgname")
+conflicts=(${provides[@]})
+source=("$_dirname"::"git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_dirname"
+ printf "%s" "$(git describe --tags | cut -d "-" -f 1,3 | sed 's/.*v//' | sed 's/-/./')"
+}
+
+build() {
+ cd "$srcdir/$_dirname"
+ python -m build --no-isolation --wheel
+}
+
+check() {
+ cd "$srcdir/$_dirname"
+ python -m pytest
+}
+
+
+package() {
+ cd "$srcdir/$_dirname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}
+