summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-09-03 11:01:20 -0400
committerGuillaume Horel2020-09-03 11:01:20 -0400
commitb1ba661ed7f847888570403243576284b5c97565 (patch)
treeb2b5097ad61ba345ba7e7d1f0ded8b5e1232a56d
parent1dce79f865a019d1c3c9ccdc721941c275c1ed58 (diff)
downloadaur-b1ba661ed7f847888570403243576284b5c97565.tar.gz
update checkdepends
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 448aa7dc4fba..4a2eb4e91bcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = python-pyarrow
checkdepends = python-hypothesis
checkdepends = python-pytest
checkdepends = python-pytest-lazy-fixture
+ checkdepends = python-pytz
makedepends = cmake
makedepends = cython
makedepends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index 63d12bb5f15d..ac0c4e9a1629 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname='python-pyarrow'
+_pkgname='arrow-apache-arrow'
pkgver=1.0.1
pkgrel=1
pkgdesc="A columnar in-memory analytics layer for big data."
@@ -8,7 +9,7 @@ arch=('x86_64')
url="https://arrow.apache.org"
license=('Apache')
depends=('arrow')
-checkdepends=('git' 'python-brotli' 'python-hypothesis' 'python-pytest' 'python-pytest-lazy-fixture')
+checkdepends=('git' 'python-brotli' 'python-hypothesis' 'python-pytest' 'python-pytest-lazy-fixture' 'python-pytz')
optdepends=('python-fsspec')
makedepends=('cmake' 'cython' 'python-setuptools')
source=("https://github.com/apache/arrow/archive/apache-arrow-$pkgver.tar.gz"
@@ -17,12 +18,12 @@ sha256sums=('dac59f4d42416224419c020ed2e8f8371e85c1d9ff4368ed5b5c026ee28d3fd4'
'b6efa43faf51ea69a5e60ccbfc390caaab5c898025f08db79eda76de4bfbd09e')
prepare(){
- cd "$srcdir"
- patch -p0 < "tensorflow-abi.patch"
+ cd "$_pkgname-$pkgver"
+ patch -p1 -i ../tensorflow-abi.patch
}
build(){
- cd "$srcdir/arrow-apache-arrow-$pkgver/python"
+ cd "$_pkgname-$pkgver/python"
ARROW_HOME=/usr PARQUET_HOME=/usr \
python setup.py build_ext --build-type=release \
--with-parquet --with-plasma --with-flight --with-tensor --with-orc \
@@ -31,7 +32,7 @@ build(){
}
package(){
- cd "$srcdir/arrow-apache-arrow-$pkgver/python"
+ cd "$_pkgname-$pkgver/python"
ARROW_HOME=/usr PARQUET_HOME=/usr \
python setup.py build_ext --build-type=release \
--with-parquet --with-plasma --with-flight --with-tensor --with-orc \
@@ -39,7 +40,7 @@ package(){
}
check(){
- cd "$srcdir/arrow-apache-arrow-$pkgver"
+ cd "$_pkgname-$pkgver"
git clone https://github.com/apache/arrow-testing.git testing
cd python
ARROW_TEST_DATA="$srcdir/arrow-apache-arrow-$pkgver/testing/data" PARQUET_HOME=/usr pytest pyarrow/tests