summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-03 01:06:05 +1100
committerPumpkinCheshire2020-11-03 01:06:05 +1100
commit0369648d0944e2c6365e250d076bcc5e8eb16a03 (patch)
tree198d926ebc5af9be75f600dcc883c1dc11c7464c
parentaf2b95ed03a38bf5aa87c9fbc811d067b2c4c563 (diff)
downloadaur-0369648d0944e2c6365e250d076bcc5e8eb16a03.tar.gz
move some optdepends back to depends.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD9
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 217081f1b072..60a7e4b8fca5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = python-pyautogui
pkgdesc = A cross-platform GUI automation Python module for human beings
pkgver = 0.9.52
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/asweigart/pyautogui
arch = any
license = BSD
makedepends = python
makedepends = python-setuptools
depends = python-xlib
- depends = python-pillow
+ depends = python-pymsgbox
+ depends = python-pytweening
+ depends = python-pyscreeze
+ depends = python-mouseinfo
optdepends = tk: windowing tool kit
optdepends = scrot: screenshot tool
- optdepends = python-pyscreeze: screenshot tool
- optdepends = python-pytweening: tweening / easing functions support
- optdepends = python-mouseinfo: display XY position and RGB color information for the pixel currently under the mouse.
- optdepends = python-pymsgbox: display message boxes
provides = python-pyautogui
conflicts = python-pyautogui-git
source = https://files.pythonhosted.org/packages/source/P/PyAutoGUI/PyAutoGUI-0.9.52.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 2b0f8db15471..e87aaddfd48a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,19 @@
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Clemmitt M. Sigler <cmsigler dot online at gmail dot com>
# Contributor: xantares
+
pkgname=python-pyautogui
_name=PyAutoGUI
pkgver=0.9.52
-pkgrel=2
+pkgrel=3
pkgdesc="A cross-platform GUI automation Python module for human beings"
arch=('any')
url="https://github.com/asweigart/pyautogui"
license=('BSD')
-depends=('python-xlib' 'python-pillow')
-optdepends=('tk: windowing tool kit' 'scrot: screenshot tool' 'python-pyscreeze: screenshot tool' 'python-pytweening: tweening / easing functions support' 'python-mouseinfo: display XY position and RGB color information for the pixel currently under the mouse.' 'python-pymsgbox: display message boxes')
+depends=('python-xlib' 'python-pymsgbox' 'python-pytweening' 'python-pyscreeze' 'python-mouseinfo')
+optdepends=('tk: windowing tool kit' 'scrot: screenshot tool')
# 'python-pygetwindow' - Not compatible with Linux yet
+ # 'python-pillow' - is provided by mouseinfo
makedepends=('python' 'python-setuptools')
provides=('python-pyautogui')
conflicts=('python-pyautogui-git')
@@ -28,6 +30,5 @@ build() {
package() {
cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
-
install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
}