summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-11-02 15:34:06 +1100
committerPumpkinCheshire2020-11-02 15:34:06 +1100
commitaf2b95ed03a38bf5aa87c9fbc811d067b2c4c563 (patch)
treea13ae95611cf405074f49d0a8b67ca449bc8abd0
parenta4dd3fa07a65e4d30df7b52e189c243d73a7d71b (diff)
downloadaur-af2b95ed03a38bf5aa87c9fbc811d067b2c4c563.tar.gz
Adopt this package, put some depends to optdepends.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD18
2 files changed, 24 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cf1ca7574d6..217081f1b072 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,23 @@
pkgbase = python-pyautogui
pkgdesc = A cross-platform GUI automation Python module for human beings
pkgver = 0.9.52
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/asweigart/pyautogui
arch = any
license = BSD
+ makedepends = python
makedepends = python-setuptools
- depends = python-pymsgbox
- depends = python-pyscreeze
- depends = python-pytweening
- depends = python-mouseinfo
- source = https://pypi.org/packages/source/P/PyAutoGUI/PyAutoGUI-0.9.52.tar.gz
+ depends = python-xlib
+ depends = python-pillow
+ optdepends = tk: windowing tool kit
+ optdepends = scrot: screenshot tool
+ optdepends = python-pyscreeze: screenshot tool
+ optdepends = python-pytweening: tweening / easing functions support
+ optdepends = python-mouseinfo: display XY position and RGB color information for the pixel currently under the mouse.
+ optdepends = python-pymsgbox: display message boxes
+ provides = python-pyautogui
+ conflicts = python-pyautogui-git
+ source = https://files.pythonhosted.org/packages/source/P/PyAutoGUI/PyAutoGUI-0.9.52.tar.gz
sha256sums = a486cb6b818bcbcdf98b48d010c7cee964134fa394b756e8ce6e50d43b58ecc8
pkgname = python-pyautogui
diff --git a/PKGBUILD b/PKGBUILD
index d9048573d794..2b0f8db15471 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,32 @@
-# Maintainer: Jack Rubacha <rubacha.jack03@gmail.com>
+# Maintainer: pupmkincheshire <sollyonzou@gmail.com>
+# Contributor: Jack Rubacha <rubacha.jack03@gmail.com>
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Clemmitt M. Sigler <cmsigler dot online at gmail dot com>
# Contributor: xantares
pkgname=python-pyautogui
_name=PyAutoGUI
pkgver=0.9.52
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform GUI automation Python module for human beings"
arch=('any')
url="https://github.com/asweigart/pyautogui"
license=('BSD')
-depends=('python-pymsgbox' 'python-pyscreeze' 'python-pytweening' 'python-mouseinfo')
+depends=('python-xlib' 'python-pillow')
+optdepends=('tk: windowing tool kit' 'scrot: screenshot tool' 'python-pyscreeze: screenshot tool' 'python-pytweening: tweening / easing functions support' 'python-mouseinfo: display XY position and RGB color information for the pixel currently under the mouse.' 'python-pymsgbox: display message boxes')
# 'python-pygetwindow' - Not compatible with Linux yet
-makedepends=('python-setuptools')
-source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+makedepends=('python' 'python-setuptools')
+provides=('python-pyautogui')
+conflicts=('python-pyautogui-git')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
sha256sums=('a486cb6b818bcbcdf98b48d010c7cee964134fa394b756e8ce6e50d43b58ecc8')
build() {
- cd "$_name-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python setup.py build
}
package() {
- cd "$_name-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname"