summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2020-01-19 19:03:55 -0700
committeryochananmarqos2020-01-19 19:03:55 -0700
commitf6d8e1ff6a0be8c566072fa91e1967747538d2db (patch)
treed293c2edc8d9b109fd2646b5c5473f6518255611
parent115feebb18df990220e4698ed3316df038d01772 (diff)
downloadaur-f6d8e1ff6a0be8c566072fa91e1967747538d2db.tar.gz
updated to 0.9.48
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 22 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ce80cab95fd..e8c5b7958ff6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
pkgbase = python-pyautogui
pkgdesc = A cross-platform GUI automation Python module for human beings
- pkgver = 0.9.38
+ pkgver = 0.9.48
pkgrel = 1
url = https://github.com/asweigart/pyautogui
arch = any
license = BSD
- makedepends = python-setuptools
- depends = python-xlib
- depends = python-pillow
+ depends = python-pymsgbox
depends = python-pyscreeze
depends = python-pytweening
- depends = python-pymsgbox
- source = https://pypi.io/packages/source/P/PyAutoGUI/PyAutoGUI-0.9.38.tar.gz
- sha256sums = 52dae786359a51f6dcd64037fe0d703bb86e881059fe99af1fe4662cdf0d7d9e
+ depends = python-mouseinfo
+ source = https://files.pythonhosted.org/packages/source/P/PyAutoGUI/PyAutoGUI-0.9.48.tar.gz
+ sha256sums = e91a25c1cdf826e7d0581775b5fbe47f7e12af79e0eb9dc3e1488ba99f2e0c60
pkgname = python-pyautogui
-pkgname = python2-pyautogui
-
diff --git a/PKGBUILD b/PKGBUILD
index 29d7fcb584ff..aa8ecd26e618 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
-# Maintainer: Clemmitt Sigler <cmsigler (dot) online (at) gmail (dot) com>
-# Contributor: Michel Zou <xantares (at) archlinux (dot) org>
-
-pkgname=('python-pyautogui' 'python2-pyautogui')
-pkgver=0.9.38
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Clemmitt M. Sigler <cmsigler dot online at gmail dot com>
+# Contributor: xantares
+pkgname=python-pyautogui
+_name=PyAutoGUI
+pkgver=0.9.48
pkgrel=1
pkgdesc="A cross-platform GUI automation Python module for human beings"
arch=('any')
url="https://github.com/asweigart/pyautogui"
license=('BSD')
-makedepends=('python-setuptools')
-depends=('python-xlib' 'python-pillow' 'python-pyscreeze' 'python-pytweening' 'python-pymsgbox')
-
-source=("https://pypi.io/packages/source/P/PyAutoGUI/PyAutoGUI-${pkgver}.tar.gz")
-sha256sums=('52dae786359a51f6dcd64037fe0d703bb86e881059fe99af1fe4662cdf0d7d9e')
+depends=('python-pymsgbox' 'python-pyscreeze' 'python-pytweening' 'python-mouseinfo')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('e91a25c1cdf826e7d0581775b5fbe47f7e12af79e0eb9dc3e1488ba99f2e0c60')
-package_python-pyautogui() {
- cd "$srcdir/PyAutoGUI-${pkgver}"
- python setup.py install --root="$pkgdir" --optimize=1
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
}
-package_python2-pyautogui() {
- cd "$srcdir/PyAutoGUI-${pkgver}"
- python2 setup.py install --root="$pkgdir" --optimize=1
-}
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
-# vim:set ts=2 sw=2 ft=sh et:
+ install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
+}