summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-19 12:32:47 -0500
committerclintval2017-12-19 12:32:47 -0500
commit63b9c4708cb889a5aadba6334075ba92020f0686 (patch)
tree4b3e08c4ed0f381feed24bf00b2df77b2a8402c5
downloadaur-63b9c4708cb889a5aadba6334075ba92020f0686.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD31
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f025651aeb52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python-pybedtools
+ pkgdesc = Python wrapper for Aaron Quinlan's bedtools.
+ pkgver = 0.7.10
+ pkgrel = 1
+ url = http://daler.github.io/pybedtools
+ arch = any
+ license = GPL2
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-pysam>=0.8.1
+ depends = python-six
+ optdepends = bedtools: more-or-less required by namesake
+ optdepends = htslib: for working with SAM/BAM/CRAM files
+ optdepends = python-matplotlib: for plotting genomic intervals
+ optdepends = ucsc-kent-genome-tools: for bedgraph to bigwig conversions
+ provides = python-pybedtools
+ conflicts = python-pybedtools
+ options = !emptydirs
+ source = https://github.com/daler/pybedtools/archive/v0.7.10.tar.gz
+ md5sums = 2791d8005a3ce286e597de5adc68a369
+
+pkgname = python-pybedtools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f53659d50593
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-pybedtools'
+pkgver=0.7.10
+pkgrel=1
+pkgdesc="Python wrapper for Aaron Quinlan's bedtools."
+arch=('any')
+url="http://daler.github.io/pybedtools"
+license=('GPL2')
+depends=(
+ 'python'
+ 'python-numpy'
+ 'python-pandas'
+ 'python-pysam>=0.8.1'
+ 'python-six')
+makedepends=('cython' 'python-setuptools')
+optdepends=(
+ 'bedtools: more-or-less required by namesake'
+ 'htslib: for working with SAM/BAM/CRAM files'
+ 'python-matplotlib: for plotting genomic intervals'
+ 'ucsc-kent-genome-tools: for bedgraph to bigwig conversions')
+provides=('python-pybedtools')
+conflicts=('python-pybedtools')
+options=(!emptydirs)
+source=("https://github.com/daler/${pkgname//python-/}/archive/v${pkgver}.tar.gz")
+md5sums=('2791d8005a3ce286e597de5adc68a369')
+
+package() {
+ cd "${srcdir}/${pkgname//python-/}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}