summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-20 21:42:39 -0500
committerclintval2017-12-20 21:42:39 -0500
commit7bc24aca1198700a4b5595fa46d96a2f59bcc8a7 (patch)
treea76cd585d015ecec69e3f5cb2245b41e355d1443
downloadaur-7bc24aca1198700a4b5595fa46d96a2f59bcc8a7.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3b53cd46847
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pybigwig
+ pkgdesc = A python extension for quick access to bigWig and bigBed files
+ pkgver = 0.3.9
+ pkgrel = 1
+ url = https://github.com/deeptools/pyBigWig
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = curl
+ depends = python
+ depends = python-numpy
+ options = !emptydirs
+ source = https://github.com/deeptools/pyBigWig/archive/0.3.9.tar.gz
+ md5sums = 1bfb0c95c0e13bb64f6cd88331dcf7ef
+
+pkgname = python-pybigwig
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe51142c672f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-pybigwig'
+pkgver=0.3.9
+pkgrel=1
+pkgdesc="A python extension for quick access to bigWig and bigBed files"
+arch=('any')
+url="https://github.com/deeptools/pyBigWig"
+license=('MIT')
+depends=('curl' 'python' 'python-numpy')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("https://github.com/deeptools/pyBigWig/archive/${pkgver}.tar.gz")
+md5sums=('1bfb0c95c0e13bb64f6cd88331dcf7ef')
+
+package() {
+ cd "${srcdir}/pyBigWig-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}