summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanda Lukeš2024-05-07 14:35:56 +0200
committerStanda Lukeš2024-05-07 14:35:56 +0200
commit4695783af823abf0d70c984ed2bdf01c948cc7fb (patch)
tree3895c0839905e13d9ae32315ca731daceb85d19e
downloadaur-4695783af823abf0d70c984ed2bdf01c948cc7fb.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..347124b19c75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pybind11-stubgen
+ pkgdesc = PEP 561 type stubs generator for pybind11 modules
+ pkgver = 2.5.1
+ pkgrel = 1
+ url = https://github.com/sizmailov/pybind11-stubgen
+ arch = x86_64
+ license = BSD
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ depends = pybind11
+ source = pybind11-stubgen-2.5.1::git+https://github.com/sizmailov/pybind11-stubgen.git#tag=v2.5.1
+ sha256sums = f4bd01a51c8c6169cd96502425d32a449fd9039867bd9e9a3c0f2dee65f01ff9
+
+pkgname = python-pybind11-stubgen
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8144a1afebb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Standa Lukeš <archpkg@exyi.cz>
+_pyname="pybind11-stubgen"
+pkgname="python-${_pyname}"
+pkgver=2.5.1
+pkgrel=1
+pkgdesc="PEP 561 type stubs generator for pybind11 modules"
+arch=(x86_64)
+url="https://github.com/sizmailov/pybind11-stubgen"
+license=('BSD')
+makedepends=(python-build python-installer python-wheel)
+depends=(python pybind11)
+checkdepends=()
+#source=("${_pyname}-${pkgver}.tgz::https://github.com/sizmailov/pybind11-stubgen/archive/v${pkgver}.tar.gz")
+# The build complains about "listing git files failed - pretending there aren't any", so we clone the git repo
+source=("${_pyname}-${pkgver}::git+https://github.com/sizmailov/pybind11-stubgen.git#tag=v${pkgver}")
+sha256sums=('f4bd01a51c8c6169cd96502425d32a449fd9039867bd9e9a3c0f2dee65f01ff9')
+
+build() {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}