summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Brogi2017-05-06 20:37:49 +0200
committerGuillaume Brogi2017-05-28 21:51:28 +0200
commit39d85b85ab2c9230f3c69d675adf3b9d45adedd2 (patch)
tree9f933c1a17c35a6c46aaf0c78e9f80e73dc36b29
downloadaur-39d85b85ab2c9230f3c69d675adf3b9d45adedd2.tar.gz
Package the pybitbucket fork for git-repo
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD28
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed0f0c896708
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-pybitbucket_fork-git
+ pkgdesc = Tool for managing remote repositories from your git CLI!
+ pkgver = r378.6a2fba5
+ pkgrel = 1
+ url = https://github.com/guyzmo/pybitbucket
+ arch = any
+ license = GPL2
+ makedepends = python-setuptools
+ makedepends = python-pip
+ depends = python
+ depends = python-future
+ depends = python-six
+ depends = python-requests
+ depends = python-requests-oauthlib
+ depends = python-oauthlib
+ depends = python-uritemplate
+ depends = python-simplejson
+ depends = python-voluptuous
+ provides = python-pybitbucket
+ conflicts = python-pybitbucket
+ source = python-pybitbucket_fork-git::git+https://github.com/guyzmo/pybitbucket
+ sha256sums = SKIP
+
+pkgname = python-pybitbucket_fork-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a5461c51373
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Guillaume Brogi <gui-gui at netcourrier dot com>
+pkgname=python-pybitbucket_fork-git
+pkgver=r378.6a2fba5
+pkgrel=1
+provides=('python-pybitbucket')
+conflicts=('python-pybitbucket')
+pkgdesc="Tool for managing remote repositories from your git CLI!"
+arch=('any')
+url="https://github.com/guyzmo/pybitbucket"
+license=('GPL2')
+depends=('python' 'python-future' 'python-six' 'python-requests' 'python-requests-oauthlib' 'python-oauthlib' 'python-uritemplate' 'python-simplejson' 'python-voluptuous')
+makedepends=('python-setuptools' 'python-pip')
+source=("${pkgname}::git+${url}")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}
+