summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2022-02-14 20:45:36 +1100
committerRhinoceros2022-02-14 20:45:36 +1100
commit77102cce2349322f8d1948ef8225a10e4071ebf9 (patch)
treecff9158f39cd6db88ac62ae9edfb943bc39cf557
parent03fabce8589345a9ceb1bce2ad707b2f4717112e (diff)
downloadaur-77102cce2349322f8d1948ef8225a10e4071ebf9.tar.gz
Update to 0.22.r52.g42070d9-1
* Fix: * sources * url * licence * provides * makedepends * Other minor style fixes and remove useless code
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 27 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e27d557fb8f7..2f2e1b03a5c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,18 @@
-# Generated by mksrcinfo v8
-# Sun Jan 31 21:24:12 UTC 2016
pkgbase = python-pybluez-git
pkgdesc = Python wrapper for the BlueZ Bluetooth stack
- pkgver = 0.22.r52.g42070d9
+ pkgver = 0.22.r238.g5096047
pkgrel = 1
- url = https://github.com/karulis/pybluez
+ url = https://github.com/pybluez/pybluez
arch = any
- license = GPL2
- makedepends = python
- makedepends = bluez-libs
- makedepends = mercurial
+ license = GPL
makedepends = boost
depends = python
depends = bluez-libs
+ provides = python-pybluez
conflicts = python-pybluez
- source = git+https://github.com/karulis/pybluez.git
- source = hg+https://bitbucket.org/OscarAcena/pygattlib
- md5sums = SKIP
- md5sums = SKIP
+ source = git+https://github.com/pybluez/pybluez.git
+ source = git+https://github.com/oscaracena/pygattlib.git
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = python-pybluez-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 13456c495b20..c012c1ac8ea4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
-# $Id: PKGBUILD 66132 2012-02-23 01:40:38Z backpackjoe $
-# Maintainer: Tobias Simetsreiter <tobias@tsimnet.eu>
+# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
+# Contributor: Tobias Simetsreiter <tobias@tsimnet.eu>
pkgname=python-pybluez-git
_gitname=pybluez
-pkgver=0.22.r52.g42070d9
+pkgver=0.22.r238.g5096047
pkgrel=1
-pkgdesc="Python wrapper for the BlueZ Bluetooth stack"
+pkgdesc='Python wrapper for the BlueZ Bluetooth stack'
arch=('any')
-url="https://github.com/karulis/pybluez"
-license=('GPL2')
-makedepends=('python' 'bluez-libs' 'mercurial' 'boost')
+url='https://github.com/pybluez/pybluez'
+license=('GPL')
depends=('python' 'bluez-libs')
-conflicts=("python-pybluez")
-source=("git+https://github.com/karulis/pybluez.git" "hg+https://bitbucket.org/OscarAcena/pygattlib")
-md5sums=('SKIP' 'SKIP')
+makedepends=('boost')
+provides=('python-pybluez')
+conflicts=('python-pybluez')
+source=('git+https://github.com/pybluez/pybluez.git'
+ 'git+https://github.com/oscaracena/pygattlib.git')
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
- cd "$srcdir/${_gitname}"
- git describe --long | sed 's/^FOO-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${_gitname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/pygattlib"
- sed "s/boost_python-py34/boost_python3/g" setup.py > new_setup.py
+ cd pygattlib
+ sed 's/boost_python-py34/boost_python3/g' setup.py > new_setup.py
mv new_setup.py setup.py
- python setup.py install --root=$pkgdir
+ python setup.py install --root="$pkgdir"
cd "$srcdir/${_gitname}"
- python setup.py install --root=$pkgdir
+ python setup.py install --root="$pkgdir"
# ln -s bluetooth/_bluetooth.so $pkgdir/usr/lib/python3.3/site-packages/_bluetooth.so
}