summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-20 21:08:20 -0500
committerclintval2017-12-20 21:08:20 -0500
commitaac32dce00b93d3f7af45b45e97e8e1c2a5645b0 (patch)
tree3545699c9c82aa123a135b8dbb2d402a5f2a91f3
downloadaur-python-pybwa.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD21
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab9c213eeeb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-pybwa
+ pkgdesc = Python libraries to interact with the BWA mapper.
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/VDBWRAIR/pyBWA
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = bash
+ depends = bwa
+ depends = python
+ depends = python-biopython
+ provides = python-pybwa
+ conflicts = python-pybwa
+ options = !emptydirs
+ source = https://github.com/VDBWRAIR/pyBWA/archive/v0.2.4.tar.gz
+ md5sums = 0789be5883fa70c9c4a40ebf2d0d545d
+
+pkgname = python-pybwa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9fb7f20d935
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-pybwa'
+pkgver=0.2.4
+pkgrel=1
+pkgdesc="Python libraries to interact with the BWA mapper."
+arch=('any')
+url="https://github.com/VDBWRAIR/pyBWA"
+license=('BSD')
+depends=('bash' 'bwa' 'python' 'python-biopython')
+makedepends=('python-setuptools')
+provides=('python-pybwa')
+conflicts=('python-pybwa')
+options=(!emptydirs)
+source=("https://github.com/VDBWRAIR/pyBWA/archive/v${pkgver}.tar.gz")
+md5sums=('0789be5883fa70c9c4a40ebf2d0d545d')
+
+package() {
+ cd "${srcdir}/pyBWA-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+}