summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Hornich2018-12-01 17:46:56 +0100
committerJulian Hornich2018-12-01 17:46:56 +0100
commit228db4161a0f1a0b806eb3bb7a713010fccbd52d (patch)
tree3411020d5d9a05f2c66f1e87fc26813a61f998c6
downloadaur-228db4161a0f1a0b806eb3bb7a713010fccbd52d.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87b568d23889
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pycachesim-git
+ pkgdesc = Python Cache Hierarchy Simulator
+ pkgver = r84
+ pkgrel = 1
+ url = https://github.com/RRZE-HPC/pycachesim
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ depends = python
+ provides = pycachesim
+ source = git+https://github.com/RRZE-HPC/pycachesim.git
+ sha256sums = SKIP
+
+pkgname = python-pycachesim-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5313d8d16b0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Julian Hornich <julianhornich@googlemail.com>
+
+pkgname=python-pycachesim-git
+pkgrel=1
+pkgver=r84
+pkgdesc="Python Cache Hierarchy Simulator"
+arch=('i686' 'x86_64')
+url="https://github.com/RRZE-HPC/pycachesim"
+license=('GPLv3')
+# iaca does currently not build from AUR. You might want to install it by hand and uncomment it here
+depends=('python' )
+makedepends=('git')
+source=('git+https://github.com/RRZE-HPC/pycachesim.git')
+sha256sums=('SKIP')
+provides=('pycachesim')
+
+pkgver() {
+ cd ${srcdir}/pycachesim
+ echo "r"$(git rev-list --count master)
+}
+
+package() {
+ cd ${srcdir}/pycachesim
+
+ # install package
+ python setup.py install --root="${pkgdir}"
+
+ # license
+ install -Dm644 ${srcdir}/pycachesim/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}