summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-02-19 13:53:14 -0700
committerMark Wagie2020-02-19 13:53:14 -0700
commitcccc4f01334db7a49920d04d613c68f75002b751 (patch)
treeaf76db29a4b72c611e7fa50c734fccece4ecccc6
parentb1cbb2cbed2a0d3377e19047e04748ce1636662a (diff)
downloadaur-cccc4f01334db7a49920d04d613c68f75002b751.tar.gz
add dependencies
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 25 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 687244da49e9..412e12027778 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
pkgbase = python-pycaption
- pkgdesc = Closed caption converter
+ pkgdesc = Python module to read/write popular video caption formats
pkgver = 1.0.1
pkgrel = 1
url = https://github.com/pbs/pycaption
arch = any
- makedepends = python3
- depends = python
- source = https://pypi.python.org/packages/24/1f/dc3e07788a14ab287a5ec922490e1d646216e838d038ed3db23c1517ce59/pycaption-1.0.1.tar.gz
- md5sums = d5c11f5e4d1c2c94027029e25c7f732b
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-beautifulsoup4
+ depends = python-lxml
+ depends = python-cssutils
+ depends = python-future
+ depends = python-six
+ source = https://pypi.org/packages/source/p/pycaption/pycaption-1.0.1.tar.gz
+ sha256sums = 1000447d92903c2044838f899578c6b8a2e853e9bef4a179b48415e367ea5038
pkgname = python-pycaption
diff --git a/PKGBUILD b/PKGBUILD
index 09035022069b..0514f342ff71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,25 @@
-#Automatically generated by pip2arch on 2018-03-11
-# bump
+# Maintainer:
+# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: bitwave
pkgname=python-pycaption
+_name=${pkgname#python-}
pkgver=1.0.1
pkgrel=1
-pkgdesc="Closed caption converter"
-url="https://github.com/pbs/pycaption"
-depends=('python' )
-makedepends=('python3' )
-license=('')
+pkgdesc="Python module to read/write popular video caption formats"
arch=('any')
-source=('https://pypi.python.org/packages/24/1f/dc3e07788a14ab287a5ec922490e1d646216e838d038ed3db23c1517ce59/pycaption-1.0.1.tar.gz')
-md5sums=('d5c11f5e4d1c2c94027029e25c7f732b')
+url="https://github.com/pbs/pycaption"
+license=('Apache')
+depends=('python-beautifulsoup4' 'python-lxml' 'python-cssutils' 'python-future' 'python-six')
+makedepends=('python-setuptools')
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('1000447d92903c2044838f899578c6b8a2e853e9bef4a179b48415e367ea5038')
build() {
- cd $srcdir/pycaption-1.0.1
- python setup.py build
+ cd "$_name-$pkgver"
+ python setup.py build
}
package() {
- cd $srcdir/pycaption-1.0.1
- python setup.py install --root="$pkgdir" --optimize=1
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}