summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael2020-10-01 01:19:50 -0400
committerMichael2020-10-01 01:19:50 -0400
commitd722b8591d9765598c11485ce5e5e667ec34434a (patch)
treec92a786a0995f00f0efda4a7b8f034dfe18b8321
downloadaur-d722b8591d9765598c11485ce5e5e667ec34434a.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3ef0078d87a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pycdlib-git
+ pkgdesc = Python library to read and write ISOs
+ pkgver = 1.10.0.42.g2d41d2d
+ pkgrel = 1
+ url = https://github.com/clalancette/pycdlib
+ arch = any
+ license = LGPL2.1
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ provides = python-pycdlib
+ conflicts = python-pycdlib
+ source = pycdlib::git+https://github.com/clalancette/pycdlib.git
+ sha512sums = SKIP
+
+pkgname = python-pycdlib-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9f79c96769a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+
+# Maintainer: Michael Riegert <michael at eowyn net>
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Contributor: Sibren Vasse <arch@sibrenvasse.nl>
+# Contributor: Daniel M. Capella <polyzen@archlinux.info>
+# Contributor: Morten Linderud <morten@linderud.pw>
+
+pkgname=python-pycdlib-git
+_name=pycdlib
+pkgver=1.10.0.42.g2d41d2d
+pkgrel=1
+pkgdesc='Python library to read and write ISOs'
+arch=('any')
+url=https://github.com/clalancette/pycdlib
+license=('LGPL2.1')
+depends=('python')
+makedepends=('python-setuptools' 'git')
+source=("$_name::git+${url}.git")
+sha512sums=('SKIP')
+provides=('python-pycdlib')
+conflicts=('python-pycdlib')
+
+pkgver() {
+ cd "$_name"
+ git describe --long --tags | sed 's/v//g;s/-/./g'
+}
+
+build() {
+ cd "$_name"
+ python setup.py build
+}
+
+package() {
+ cd "$_name"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}