summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2018-10-12 22:08:35 -0400
committerDaniel M. Capella2018-10-12 22:11:00 -0400
commit9209ad049952075130d4d97916a8cccd2dc7d5ef (patch)
tree90bd3f31e2f3a5dc8dd3d1dbd6d0294c39842925
parentecf2c37b867012ecc94f4a80989dc1e71687d117 (diff)
downloadaur-9209ad049952075130d4d97916a8cccd2dc7d5ef.tar.gz
2.3.0
Also source from PyPI (which doesn't include examples/).
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 16 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f35dbb31c3a..b771b4a78440 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,21 @@
# Generated by mksrcinfo v8
-# Thu Mar 22 08:56:19 UTC 2018
+# Sat Oct 13 02:08:29 UTC 2018
pkgbase = python-pychromecast
pkgdesc = Library for Python 2 and 3 to communicate with the Google Chromecast
- pkgver = 2.1.0
+ pkgver = 2.3.0
pkgrel = 1
url = https://github.com/balloob/pychromecast
arch = any
license = MIT
makedepends = python
makedepends = python-setuptools
- makedepends = python2
- makedepends = python2-setuptools
- source = python-pychromecast-2.1.0.tar.gz::https://github.com/balloob/pychromecast/archive/2.1.0.tar.gz
- sha512sums = d532bfe50118c647a69f26c7dffe25dc30ede80253f7eb6d33f67ba5bddaf189608285559a5d3be80110300ca7b217ae384b1ad323a0241bc7756903939e2c0f
-
-pkgname = python-pychromecast
depends = python
depends = python-protobuf
depends = python-requests
depends = python-zeroconf
depends = python-six
+ source = https://files.pythonhosted.org/packages/source/p/pychromecast/PyChromecast-2.3.0.tar.gz
+ sha512sums = 44a2cb80e5a3a3c8c5ca3dd6cb55bf50c4c536afc4828f9d7c14c9792ec59bf5bb88988448aeaf33b5d5472f60d7f6ca39f0ea5f4f3896d5188654b962065abe
-pkgname = python2-pychromecast
- depends = python2
- depends = python2-protobuf
- depends = python2-requests
- depends = python2-zeroconf
- depends = python2-six
+pkgname = python-pychromecast
diff --git a/PKGBUILD b/PKGBUILD
index ccdd40f2e575..b6343cd942ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,27 @@
# Maintainer: Daniel M. Capella <polyzen@archlinux.info>
-# Maitnainer: Morten Linderud <morten@linderud.pw>
+# Contributor: Morten Linderud <morten@linderud.pw>
-pkgbase=python-pychromecast
-pkgname=('python-pychromecast' 'python2-pychromecast')
-_pkgname=pychromecast
-pkgver=2.1.0
+_name=PyChromecast
+pkgname=python-pychromecast
+pkgver=2.3.0
pkgrel=1
pkgdesc='Library for Python 2 and 3 to communicate with the Google Chromecast'
arch=('any')
url=https://github.com/balloob/pychromecast
license=('MIT')
-makedepends=('python' 'python-setuptools'
- 'python2' 'python2-setuptools')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha512sums=('d532bfe50118c647a69f26c7dffe25dc30ede80253f7eb6d33f67ba5bddaf189608285559a5d3be80110300ca7b217ae384b1ad323a0241bc7756903939e2c0f')
-
-prepare() {
- cp -a $_pkgname-$pkgver{,-py2}
-}
+depends=('python' 'python-protobuf' 'python-requests' 'python-zeroconf' 'python-six')
+makedepends=('python' 'python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/p/pychromecast/$_name-$pkgver.tar.gz")
+sha512sums=('44a2cb80e5a3a3c8c5ca3dd6cb55bf50c4c536afc4828f9d7c14c9792ec59bf5bb88988448aeaf33b5d5472f60d7f6ca39f0ea5f4f3896d5188654b962065abe')
build() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd $_name-$pkgver
python setup.py build
-
- cd "$srcdir/$_pkgname-$pkgver-py2"
- python2 setup.py build
}
-package_python-pychromecast() {
- depends=('python' 'python-protobuf' 'python-requests' 'python-zeroconf' 'python-six')
- cd $_pkgname-$pkgver
+package() {
+ cd $_name-$pkgver
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 -t "$pkgdir"/usr/share/$pkgname/examples examples/*
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
-}
-
-package_python2-pychromecast() {
- depends=('python2' 'python2-protobuf' 'python2-requests' 'python2-zeroconf' 'python2-six')
- cd $_pkgname-$pkgver-py2
- python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 -t "$pkgdir"/usr/share/$pkgname/examples examples/*
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}