summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSibren Vasse2019-02-28 10:43:00 +0100
committerSibren Vasse2019-02-28 10:43:55 +0100
commitb438fd0d835c26eefe51589d470dd1a717cece57 (patch)
tree3b8caccc62b9cb0e0e935a035b7bef5c125fa6a9
parent61b3d710220dc9982804d464263133e2ffd458e6 (diff)
downloadaur-b438fd0d835c26eefe51589d470dd1a717cece57.tar.gz
Change source tarball to github and move setuptools to makedepends
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 820e911925dc..f1e63d1e6d66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-pychromecast
pkgdesc = Library for Python 3 to communicate with the Google Chromecast
pkgver = 2.5.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/balloob/pychromecast
arch = any
license = MIT
+ makedepends = python-setuptools
depends = python
depends = python-protobuf
depends = python-requests
@@ -12,8 +13,8 @@ pkgbase = python-pychromecast
depends = python-six
depends = python-setuptools
depends = python-casttube
- source = https://files.pythonhosted.org/packages/source/p/pychromecast/PyChromecast-2.5.2.tar.gz
- sha512sums = 8c3183ccdae59ec09d9b0444cdf03d5fed124395b37e0663ed6817e7128f65c5c6eefd70bd9daddeb55ec9312ac3df1995fe8af56d9de5a54e9a1e0214f79d7d
+ source = https://github.com/balloob/pychromecast/archive/2.5.2.tar.gz
+ sha512sums = 45398723c156df715fa244db61b219b5036c34e308147a1e12eff4e59a01f6586b8da307407579605cd4ad4cbd19cbd8f06dd2a512eda5a2a8b051dad2a9293a
pkgname = python-pychromecast
diff --git a/PKGBUILD b/PKGBUILD
index 1cde7789fca4..c1d82a369b79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,18 @@
# Contributor: Daniel M. Capella <polyzen@archlinux.info>
# Contributor: Morten Linderud <morten@linderud.pw>
-_name=PyChromecast
pkgname=python-pychromecast
+_name=${pkgname#python-}
pkgver=2.5.2
-pkgrel=1
+pkgrel=2
pkgdesc='Library for Python 3 to communicate with the Google Chromecast'
arch=('any')
url=https://github.com/balloob/pychromecast
license=('MIT')
depends=('python' 'python-protobuf' 'python-requests' 'python-zeroconf' 'python-six' 'python-setuptools' 'python-casttube')
-source=("https://files.pythonhosted.org/packages/source/p/pychromecast/$_name-$pkgver.tar.gz")
-sha512sums=('8c3183ccdae59ec09d9b0444cdf03d5fed124395b37e0663ed6817e7128f65c5c6eefd70bd9daddeb55ec9312ac3df1995fe8af56d9de5a54e9a1e0214f79d7d')
+makedepends=('python-setuptools')
+source=("https://github.com/balloob/pychromecast/archive/$pkgver.tar.gz")
+sha512sums=('45398723c156df715fa244db61b219b5036c34e308147a1e12eff4e59a01f6586b8da307407579605cd4ad4cbd19cbd8f06dd2a512eda5a2a8b051dad2a9293a')
build() {
cd $_name-$pkgver