summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis A. Altoé Falqueto2016-08-02 22:14:38 -0300
committerDenis A. Altoé Falqueto2016-08-02 22:14:38 -0300
commitb5df0c17b248ac1244d37cc6a10a88a8a5a1afd1 (patch)
tree7a2ab221b3c05d4c8cbf96d4a02b646e23f0ac0e
downloadaur-b5df0c17b248ac1244d37cc6a10a88a8a5a1afd1.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD28
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de26e056ebf5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-pychromecast-git
+ pkgdesc = Library for Python 3 to communicate with the Google Chromecast.
+ pkgver = 272.97aa41a
+ pkgrel = 1
+ url = https://github.com/balloob/pychromecast
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-requests
+ depends = python-protobuf
+ depends = python-zeroconf
+ provides = python-pychromecast
+ conflicts = python-pychromecast
+ options = !emptydirs
+ source = git+https://github.com/balloob/pychromecast.git
+ sha256sums = SKIP
+
+pkgname = python-pychromecast-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76d1b49db1ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Denis A. Altoé Falqueto <denisfalqueto@gmail.com>
+pkgname=python-pychromecast-git
+pkgver=272.97aa41a
+pkgrel=1
+pkgdesc="Library for Python 3 to communicate with the Google Chromecast."
+arch=('any')
+url="https://github.com/balloob/pychromecast"
+license=('MIT')
+depends=('python' 'python-requests' 'python-protobuf' 'python-zeroconf')
+makedepends=('python-setuptools')
+provides=('python-pychromecast')
+conflicts=('python-pychromecast')
+options=(!emptydirs)
+source=('git+https://github.com/balloob/pychromecast.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pychromecast"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/pychromecast"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: