summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-02-28 17:19:58 -0600
committerLuis Martinez2023-02-28 17:19:58 -0600
commitb60d20e7a3f3cb043d25ea474dcc756972f296ad (patch)
tree1bddcb8054e5abd80fcf853b49d0e9c5467c926b
parent29e9d78a9fe67eb082b276d1e697fcbe2a5de6e6 (diff)
downloadaur-b60d20e7a3f3cb043d25ea474dcc756972f296ad.tar.gz
update to 0.10.4
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
-rw-r--r--pychroot-0.10.1.tar.gz.sigbin566 -> 0 bytes
3 files changed, 33 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acd89af1ad83..ad85c412d1d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = python-pychroot
pkgdesc = A python library and CLI tool that simplifies chroot handling
- pkgver = 0.10.1
+ pkgver = 0.10.4
pkgrel = 1
- url = https://pypi.python.org/pypi/pychroot/
+ url = https://github.com/pkgcore/pychroot
arch = any
license = BSD
- makedepends = python
- makedepends = python-snakeoil
+ checkdepends = python-pytest
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- depends = python
+ makedepends = python-wheel
depends = python-snakeoil
- source = https://files.pythonhosted.org/packages/source/p/pychroot/pychroot-0.10.1.tar.gz
- source = pychroot-0.10.1.tar.gz.sig
- validpgpkeys = 748231EBCBD808A14F5E85D28C004C2F93481F6B
- sha512sums = 4df7f405872b693bf9ecac331927f749653b7251a49eaa10c423357f3150bbcbea73052ec4363a0f510aaeecd6b467d985402a8f764e99e67f5882e6b2ea4f97
- sha512sums = SKIP
+ source = python-pychroot::git+https://github.com/pkgcore/pychroot#tag=v0.10.4?signed
+ validpgpkeys = 74A2E6514C583FA49EEEA1094AB3E85B4F064CA3
+ sha256sums = SKIP
pkgname = python-pychroot
-
diff --git a/PKGBUILD b/PKGBUILD
index 74f0cce782e5..46d512c444cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,38 @@
-# Maintainer: brent s. <bts[at]square-r00t[dot]net>
-validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: brent s. <bts[at]square-r00t[dot]net>
# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
# News updates for packages can be followed at https://devblog.square-r00t.net
pkgname=python-pychroot
-pkgver=0.10.1
+_pkg="${pkgname#python-}"
+pkgver=0.10.4
pkgrel=1
pkgdesc="A python library and CLI tool that simplifies chroot handling"
arch=('any')
-url="https://pypi.python.org/pypi/pychroot/"
+url='https://github.com/pkgcore/pychroot'
license=('BSD')
-depends=('python' 'python-snakeoil')
-makedepends=('python' 'python-snakeoil' 'python-setuptools')
-_pkgname=pychroot
-install=
-changelog=
-noextract=()
-source=("https://files.pythonhosted.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
- "${_pkgname}-${pkgver}.tar.gz.sig")
-sha512sums=('4df7f405872b693bf9ecac331927f749653b7251a49eaa10c423357f3150bbcbea73052ec4363a0f510aaeecd6b467d985402a8f764e99e67f5882e6b2ea4f97'
- 'SKIP')
+depends=('python-snakeoil')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+checkdepends=('python-pytest')
+source=("$pkgname::git+$url#tag=v$pkgver?signed")
+sha256sums=('SKIP')
+validpgpkeys=('74A2E6514C583FA49EEEA1094AB3E85B4F064CA3') ## Tim Harder
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python3 setup.py build || return 1
+ cd "$pkgname"
+ python -m build --wheel --no-isolation
+}
+
+check() {
+ cd "$pkgname"
+ PYTHONPATH="$PWD/src" pytest -x
}
package() {
- PYVER=$(python --version | sed -re 's/^Python[[:space:]]*([0-9]\.[0-9])\.[0-9]*/\1/g')
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python3 setup.py install --root="${pkgdir}" --optimize=1 || return 1
- install -D -m 0644 ${srcdir}/${_pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- ln -sf ${pkgdir}/usr/bin/${_pkgname} ${pkgdir}/usr/lib/python${PYVER}/site-packages/pychroot/scripts/__init__.py
+ cd "$pkgname"
+ python -m installer --destdir "$pkgdir" dist/*.whl
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -dv "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -sv "$_site/$_pkg-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
}
diff --git a/pychroot-0.10.1.tar.gz.sig b/pychroot-0.10.1.tar.gz.sig
deleted file mode 100644
index a230eaab5801..000000000000
--- a/pychroot-0.10.1.tar.gz.sig
+++ /dev/null
Binary files differ