summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoradrien10182019-10-16 13:11:03 +0800
committeradrien10182019-10-16 13:11:03 +0800
commit4111d3d045feb1a0f67e2edf5404fe4580bd70e4 (patch)
tree825daf6dd2d4d91baca67023684e257a27430704
downloadaur-4111d3d045feb1a0f67e2edf5404fe4580bd70e4.tar.gz
First commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff40d42272a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pycld2
+ pkgdesc = Python bindings for the Compact Langauge Detect 2 (CLD2)
+ pkgver = 0.41
+ pkgrel = 1
+ url = https://github.com/aboSamoor/pycld2
+ arch = i686
+ arch = x86_64
+ makedepends = python-setuptools
+ provides = python-pycld2
+ source = https://files.pythonhosted.org/packages/source/p/pycld2/pycld2-0.41.tar.gz
+ sha256sums = a42f6e974df8fdd70685c2baa8a9f523069a260e1140ce604fb9f1fb6c3064df
+
+pkgname = python-pycld2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61a610f0f243
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Adrien Wu <adrien.sf.wu@gmail.com>
+pkgname=python-pycld2
+pkgver=0.41
+pkgrel=1
+pkgdesc="Python bindings for the Compact Langauge Detect 2 (CLD2)"
+url="https://github.com/aboSamoor/pycld2"
+arch=('i686' 'x86_64')
+provides=('python-pycld2')
+makedepends=('python-setuptools')
+_name="${pkgname#python-}"
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('a42f6e974df8fdd70685c2baa8a9f523069a260e1140ce604fb9f1fb6c3064df')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}