summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-12-14 13:25:19 +0300
committerCaleb Maclennan2021-12-14 13:25:19 +0300
commit014ee7cbb53ef2ca54ce36ab13f5d069ae3cdd5d (patch)
tree0228393f7da92ee048fd3c414a74373bd29d5bac
parent38ea6cb99790e6886b957bfdef63a70830ca82df (diff)
downloadaur-014ee7cbb53ef2ca54ce36ab13f5d069ae3cdd5d.tar.gz
upgpkg: python-pyclipper 1.3.0-3
Rebuild for Python 3.10
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74976b555ad5..273742161031 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python-pyclipper
pkgdesc = Cython wrapper for the C++ translation of the Angus Johnson’s Clipper library
pkgver = 1.3.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/fonttools/pyclipper
arch = x86_64
arch = i686
license = MIT
- makedepends = python-setuptools-scm
makedepends = cython
+ makedepends = python-setuptools-scm
depends = python
source = https://files.pythonhosted.org/packages/source/p/pyclipper/pyclipper-1.3.0.zip
sha256sums = 48a1b5c585aea10e5b9c0b82d6abe2642fafd9ef158b9921852bc4af815ca20c
diff --git a/PKGBUILD b/PKGBUILD
index d909ac32e1cf..b1b51802b393 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,23 +5,25 @@ pkgbase=python-pyclipper
_pkgname=pyclipper
pkgname="python-$_pkgname"
pkgver=1.3.0
-pkgrel=2
+pkgrel=3
pkgdesc='Cython wrapper for the C++ translation of the Angus Johnson’s Clipper library'
url="https://github.com/fonttools/$_pkgname"
arch=(x86_64 i686)
license=(MIT)
depends=(python)
-makedepends=(python-setuptools-scm cython)
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.zip")
+makedepends=(cython
+ python-setuptools-scm)
+_archive="$_pkgname-$pkgver"
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_archive.zip")
sha256sums=('48a1b5c585aea10e5b9c0b82d6abe2642fafd9ef158b9921852bc4af815ca20c')
build() {
- cd "$_pkgname-$pkgver"
+ cd "$_archive"
python setup.py build
}
package() {
- cd "$_pkgname-$pkgver"
+ cd "$_archive"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}