summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-01-12 14:00:15 +0300
committerCaleb Maclennan2023-01-12 14:01:56 +0300
commit5858253d83b03fad2643e38c2257bd9fe3d0c5b7 (patch)
tree609b53e3ae8713ab8731ed2a9cd65fb888c3b9f9
parent99c8171df92e354ad4a402c27f0d3f53d3fe620a (diff)
downloadaur-5858253d83b03fad2643e38c2257bd9fe3d0c5b7.tar.gz
Patch for current setuptools_scm
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
-rw-r--r--update-scm-version.patch28
3 files changed, 42 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff19ebddac23..ae7826f3b14b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyclipper
pkgdesc = Cython wrapper for the C++ translation of the Angus Johnson’s Clipper library
pkgver = 1.3.0.post4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/fonttools/pyclipper
arch = x86_64
arch = i686
@@ -11,9 +11,10 @@ pkgbase = python-pyclipper
makedepends = python-installer
makedepends = python-wheel
makedepends = python-setuptools-scm
- makedepends = python-setuptools-scm-git-archive
depends = python
source = https://files.pythonhosted.org/packages/source/p/pyclipper/pyclipper-1.3.0.post4.tar.gz
+ source = update-scm-version.patch
sha256sums = b73b19d2a1b895edcacaf4acb441e13e99b9e5fd53b9c0dfd2e1326e2bf68a7a
+ sha256sums = 0e3cf27a376ba54c15c05b2cc6bbacd55ca7984ebe326ce4d825058a69c1a087
pkgname = python-pyclipper
diff --git a/PKGBUILD b/PKGBUILD
index 6daba1068fd3..129fcbed9fb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgbase=python-pyclipper
_pyname=pyclipper
pkgname="python-$_pyname"
pkgver=1.3.0.post4
-pkgrel=1
+pkgrel=2
pkgdesc='Cython wrapper for the C++ translation of the Angus Johnson’s Clipper library'
url="https://github.com/fonttools/$_pyname"
arch=(x86_64 i686)
@@ -13,10 +13,17 @@ license=(MIT)
depends=(python)
makedepends=(cython
python-{build,installer,wheel}
- python-setuptools-scm{,-git-archive})
+ python-setuptools-scm)
_archive="$_pyname-$pkgver"
-source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
-sha256sums=('b73b19d2a1b895edcacaf4acb441e13e99b9e5fd53b9c0dfd2e1326e2bf68a7a')
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz"
+ update-scm-version.patch)
+sha256sums=('b73b19d2a1b895edcacaf4acb441e13e99b9e5fd53b9c0dfd2e1326e2bf68a7a'
+ '0e3cf27a376ba54c15c05b2cc6bbacd55ca7984ebe326ce4d825058a69c1a087')
+
+prepare() {
+ cd "$_archive"
+ patch -p1 -i "$srcdir/${source[1]}"
+}
build() {
cd "$_archive"
diff --git a/update-scm-version.patch b/update-scm-version.patch
new file mode 100644
index 000000000000..7d1afaadcd0c
--- /dev/null
+++ b/update-scm-version.patch
@@ -0,0 +1,28 @@
+From 06bdb265967fdb581336578a45e1bbcdd6594920 Mon Sep 17 00:00:00 2001
+From: Marco Rubin <20150305+Rubo3@users.noreply.github.com>
+Date: Wed, 11 Jan 2023 13:04:06 +0000
+Subject: [PATCH] Remove setuptools_scm_git_archive as it's obsolete
+
+From the project [README](https://github.com/Changaco/setuptools_scm_git_archive):
+
+```
+This plugin is obsolete. ``setuptools_scm >= 7.0.0`` supports Git archives by itself.
+```
+---
+ pyproject.toml | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/pyproject.toml b/pyproject.toml
+index b99dd09..0f68b82 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -2,8 +2,7 @@
+ requires = [
+ "setuptools",
+ "wheel",
+- "setuptools_scm",
+- "setuptools_scm_git_archive",
++ "setuptools_scm>=7.0.0",
+ "cython",
+ ]
+