summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2019-11-25 09:30:58 +0000
committerEric Engestrom2019-11-25 09:33:07 +0000
commit5bd791d4fb88c9a38b04c06a382b678b08687307 (patch)
treedb9d33a0b2bacbdb269385cba800ae9434898d0e
downloadaur-5bd791d4fb88c9a38b04c06a382b678b08687307.tar.gz
initial commit - v0.10.5
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD23
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3dc402dc948
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pycobertura
+ pkgdesc = Code coverage diff tool for Cobertura reports
+ pkgver = 0.10.5
+ pkgrel = 1
+ url = https://github.com/aconrad/pycobertura
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/aconrad/pycobertura/archive/v0.10.5.tar.gz
+ sha256sums = 909f99348e20b1bc69d68ea39c874e93ae586995fcfff4aef4a8dff07fa7f56f
+
+pkgname = python-pycobertura
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..735481e6dc71
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.pkg.*
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..028a04dc9ae0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=python-pycobertura
+pkgver=0.10.5
+pkgrel=1
+pkgdesc="Code coverage diff tool for Cobertura reports"
+arch=('x86_64')
+url="https://github.com/aconrad/pycobertura"
+license=('MIT')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('909f99348e20b1bc69d68ea39c874e93ae586995fcfff4aef4a8dff07fa7f56f')
+depends=('python')
+makedepends=('python-setuptools')
+
+build() {
+ cd "pycobertura-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "pycobertura-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}