summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2019-11-25 09:31:49 +0000
committerEric Engestrom2019-11-25 09:32:44 +0000
commitd2772cd99f4c34bb691804be3ea1b25629ca82e8 (patch)
treeb54dc96cbd98bf027e3117e9d766fda9dc9b8007
downloadaur-d2772cd99f4c34bb691804be3ea1b25629ca82e8.tar.gz
initial commit - v0.10.5+2.g25ce699cfb-1
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD30
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26f86a649e1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pycobertura-git
+ pkgdesc = Code coverage diff tool for Cobertura reports
+ pkgver = 0.10.5+2.g25ce699cfb
+ pkgrel = 1
+ url = https://github.com/aconrad/pycobertura
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = python-pycobertura=0.10.5
+ conflicts = python-pycobertura
+ source = https://github.com/aconrad/pycobertura
+ sha256sums = SKIP
+
+pkgname = python-pycobertura-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..312f36e1d2d1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.pkg.*
+/pycobertura/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..053febb1f26c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=python-pycobertura-git
+pkgver=0.10.5+2.g25ce699cfb
+pkgrel=1
+pkgdesc="Code coverage diff tool for Cobertura reports"
+arch=('x86_64')
+url="https://github.com/aconrad/pycobertura"
+license=('MIT')
+source=("git+$url")
+sha256sums=('SKIP')
+depends=('python')
+makedepends=('python-setuptools')
+conflicts=('python-pycobertura')
+provides=("python-pycobertura=${pkgver%+*}")
+
+pkgver() {
+ cd pycobertura
+ git describe --long --abbrev=10 | sed 's/^v//; s/-/+/; s/-/./'
+}
+
+build() {
+ cd pycobertura
+ python setup.py build
+}
+
+package() {
+ cd pycobertura
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}