summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoron Behar2018-08-11 20:10:30 +0300
committerDoron Behar2018-08-11 20:10:30 +0300
commit024787f5c61a8d6f96bd191f56b7564749acd09d (patch)
treee88cc2e2d4f3c6d4216e9d54cae01e11901bb49e
downloadaur-024787f5c61a8d6f96bd191f56b7564749acd09d.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb48ddb3d68c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pycscope
+ pkgdesc = Generates a cscope index of Python source trees
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = http://github.com/portante/pycscope
+ arch = any
+ license = GPL2
+ depends = python
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/source/p/pycscope/pycscope-1.2.1.tar.gz
+ md5sums = 89f1e79dbd211d9f8d96881f2e92e1fc
+
+pkgname = python-pycscope
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89577ce79f8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Doron Behar <doron.behar@gmail.com>
+
+pkgname=python-pycscope
+_name=pycscope
+pkgver=1.2.1
+pkgrel=1
+pkgdesc="Generates a cscope index of Python source trees"
+arch=('any')
+url="http://github.com/portante/pycscope"
+license=('GPL2')
+groups=()
+depends=('python')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('89f1e79dbd211d9f8d96881f2e92e1fc')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: