summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-02-13 10:39:42 -0700
committerMark Wagie2022-02-13 10:39:42 -0700
commit07d7fca143128826ddc19bddc6b6a375e2fc7ca0 (patch)
treef669500ef8ab3cca9a14e3938b10ca1dfa41c351
parente8a2434ecbb6088b71654dc84f91d31f4a95d38f (diff)
downloadaur-07d7fca143128826ddc19bddc6b6a375e2fc7ca0.tar.gz
7.1.7
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD15
-rw-r--r--PyCXX.pc4
-rw-r--r--python-pycxx-7-change-include-paths.patch28
5 files changed, 14 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 421f15e1fe2b..99263e3c7e46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = python-pycxx
pkgdesc = Write Python extensions in C++
- pkgver = 7.1.5
+ pkgver = 7.1.7
pkgrel = 1
url = http://cxx.sourceforge.net
arch = any
license = BSD
depends = python
- source = https://downloads.sourceforge.net/cxx/pycxx-7.1.5.tar.gz
+ source = https://downloads.sourceforge.net/cxx/pycxx-7.1.7.tar.gz
source = PyCXX.pc
- source = python-pycxx-7-change-include-paths.patch
- sha256sums = 9087a8574ac9caf631a8ec0b90e260828051e4bc89e1e44f4fc253ccc297d826
- sha256sums = a4597b98a7e110a18f08896f98fb12614f5c96a24642119db16672d7616f35a9
- sha256sums = 8ed381d9542265fcfbac2a50398edf49d44ac4fb59bf6b2455e45fa427fd7d42
+ sha256sums = a2798ae850460d66cbe59769c6df447ea457a5fd29c516b26a0a9ecadd4bbcb4
+ sha256sums = 84a1f4598ea64d4594cba7dff93c3e68f210e134ca3350f395015489d375a5e4
pkgname = python-pycxx
diff --git a/.gitignore b/.gitignore
index 2e31044c3d4e..fd06094ae53c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,4 +6,3 @@
!PKGBUILD
!.SRCINFO
!PyCXX.pc
-!python-pycxx-7-change-include-paths.patch
diff --git a/PKGBUILD b/PKGBUILD
index 55625b2309a1..c622f8d1d348 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=python-pycxx
_name=${pkgname#python-}
-pkgver=7.1.5
+pkgver=7.1.7
pkgrel=1
pkgdesc="Write Python extensions in C++"
arch=('any')
@@ -9,15 +9,16 @@ url="http://cxx.sourceforge.net"
license=('BSD')
depends=('python')
source=("https://downloads.sourceforge.net/cxx/$_name-$pkgver.tar.gz"
- 'PyCXX.pc'
- "$pkgname-7-change-include-paths.patch")
-sha256sums=('9087a8574ac9caf631a8ec0b90e260828051e4bc89e1e44f4fc253ccc297d826'
- 'a4597b98a7e110a18f08896f98fb12614f5c96a24642119db16672d7616f35a9'
- '8ed381d9542265fcfbac2a50398edf49d44ac4fb59bf6b2455e45fa427fd7d42')
+ 'PyCXX.pc')
+sha256sums=('a2798ae850460d66cbe59769c6df447ea457a5fd29c516b26a0a9ecadd4bbcb4'
+ '84a1f4598ea64d4594cba7dff93c3e68f210e134ca3350f395015489d375a5e4')
prepare() {
cd "$_name-$pkgver"
- patch -Np1 -i "$srcdir/$pkgname-7-change-include-paths.patch"
+
+ # Without this, pysvn fails.
+ # Src/Python3/cxxextensions.c: No such file or directory
+ sed -e "/^#include/s:Src/::" -i Src/*.{c,cxx}
}
build() {
diff --git a/PyCXX.pc b/PyCXX.pc
index d37c05345179..a87f01bb1946 100644
--- a/PyCXX.pc
+++ b/PyCXX.pc
@@ -1,9 +1,9 @@
prefix=/usr
exec_prefix=/usr
includedir=/usr/include
-srcdir=/usr/share/python3.9/CXX
+srcdir=/usr/share/python3.10/CXX
Name: PyCXX
Description: Write Python extensions in C++
-Version: 7.1.5
+Version: 7.1.7
Cflags: -I${includedir}
diff --git a/python-pycxx-7-change-include-paths.patch b/python-pycxx-7-change-include-paths.patch
deleted file mode 100644
index 4bb62d456706..000000000000
--- a/python-pycxx-7-change-include-paths.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-diff --git a/Src/cxxextensions.c b/Src/cxxextensions.c
-index 28a8e1d..cfab556 100644
---- a/Src/cxxextensions.c
-+++ b/Src/cxxextensions.c
-@@ -37,7 +37,7 @@
- #include "CXX/WrapPython.h"
-
- #if PY_MAJOR_VERSION == 2
--#include "Src/Python2/cxxextensions.c"
-+#include "Python2/cxxextensions.c"
- #else
--#include "Src/Python3/cxxextensions.c"
-+#include "Python3/cxxextensions.c"
- #endif
-diff --git a/Src/cxxsupport.cxx b/Src/cxxsupport.cxx
-index 1f2fb43..946e60d 100644
---- a/Src/cxxsupport.cxx
-+++ b/Src/cxxsupport.cxx
-@@ -37,7 +37,7 @@
- #include "CXX/WrapPython.h"
-
- #if PY_MAJOR_VERSION == 2
--#include "Src/Python2/cxxsupport.cxx"
-+#include "Python2/cxxsupport.cxx"
- #else
--#include "Src/Python3/cxxsupport.cxx"
-+#include "Python3/cxxsupport.cxx"
- #endif