summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-06 22:03:04 +0300
committerDimitris Kiziridis2020-05-06 22:03:04 +0300
commit5654e24d0af4fc2743ae810540f0503ebcf039a3 (patch)
treee311cd16fefb964ddbd682083cd0be4d5b33f188
downloadaur-5654e24d0af4fc2743ae810540f0503ebcf039a3.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..705d29609904
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-pydantic-git
+ pkgdesc = Data parsing and validation using Python type hints
+ pkgver = 1.5.1.r13.g5067508e
+ pkgrel = 1
+ url = https://pydantic-docs.helpmanual.io
+ arch = x86_64
+ license = MIT
+ checkdepends = python-pytest-cov
+ checkdepends = mypy
+ makedepends = cython
+ makedepends = git
+ depends = python
+ optdepends = python-ujson: Faster JSON parsing in pure Python
+ optdepends = python-email-validator: Enable email validation
+ provides = python-pydantic
+ source = git+https://github.com/samuelcolvin/pydantic
+ sha256sums = SKIP
+
+pkgname = python-pydantic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0314c2ef3850
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=python-pydantic-git
+pkgver=1.5.1.r13.g5067508e
+pkgrel=1
+pkgdesc='Data parsing and validation using Python type hints'
+arch=('x86_64')
+url='https://pydantic-docs.helpmanual.io'
+license=('MIT')
+provides=("${pkgname%-git}")
+depends=('python')
+makedepends=('cython' 'git')
+optdepends=('python-ujson: Faster JSON parsing in pure Python'
+ 'python-email-validator: Enable email validation')
+checkdepends=('python-pytest-cov' 'mypy')
+source=("git+https://github.com/samuelcolvin/pydantic")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pydantic
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd pydantic
+ python setup.py build
+}
+
+package() {
+ cd pydantic
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+} \ No newline at end of file