summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Coutinho2015-06-19 19:25:29 -0300
committerRenato Coutinho2015-06-19 19:25:29 -0300
commit087ce5b7bffdaf1e04d1a2e29b91ee522460ca24 (patch)
tree6096c472ea7d059e2f122e1d67eda22104348e1f
downloadaur-python-pydelay.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db07b8c619d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pydelay
+ pkgdesc = A Python tool for solving delay differential equations
+ pkgver = 0.1.1
+ pkgrel = 2
+ url = http://pydelay.sf.net
+ arch = any
+ license = MIT
+ depends = python-numpy
+ depends = python-scipy
+ depends = gcc
+ optdepends = python-matplotlib: To plot the solutions and run the examples
+ source = http://dl.sourceforge.net/project/pydelay/pydelay-0.1.1.tar.gz
+ md5sums = 6163145919477596bb4ea15edb922c5d
+
+pkgname = python-pydelay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48111ad30594
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Contributor: Thomas Dahms <thdahms@gmx.de>
+
+pkgname=python-pydelay
+pkgver=0.1.1
+pkgrel=2
+pkgdesc="A Python tool for solving delay differential equations"
+arch=('any')
+url="http://pydelay.sf.net"
+license=('MIT')
+depends=('python-numpy' 'python-scipy' 'gcc')
+optdepends=('python-matplotlib: To plot the solutions and run the examples')
+source=(http://dl.sourceforge.net/project/pydelay/pydelay-${pkgver}.tar.gz)
+md5sums=('6163145919477596bb4ea15edb922c5d')
+
+build() {
+ cd "$srcdir/pydelay-$pkgver"
+
+ python2 setup.py install --root="$pkgdir" || return 1
+}