summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2017-12-18 18:37:30 -0500
committerclintval2017-12-18 18:37:30 -0500
commitf100fc00723d828d115551000df18a4456337cee (patch)
tree36cb45ef7afb8c5865c80dac0fc67ca94ff47e8e
downloadaur-f100fc00723d828d115551000df18a4456337cee.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD37
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..877dad3281f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = python-pydna
+ pkgdesc = Python3 classes for dsDNA simulation of homologous recombination, Gibson assembly and interactive cloning
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://github.com/BjornFJohansson/pydna
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-appdirs>=1.3.0
+ depends = python-biopython>=1.65
+ depends = python-networkx>=1.8.1
+ depends = python-orderedset>=2.0
+ depends = python-prettytable>=0.7.2
+ depends = python-pyparsing>=2.1.10
+ depends = python-requests
+ optdepends = python-matplotlib: gel simulation
+ optdepends = python-mpldatacursor: gel simulation
+ optdepends = python-numpy: gel simulation
+ optdepends = python-pint>=0.7.2: gel simulation
+ optdepends = python-scipy: gel simulation
+ provides = python-pydna
+ conflicts = python-pydna
+ options = !emptydirs
+ source = https://github.com/BjornFJohansson/pydna/archive/2.0.1.tar.gz
+ md5sums = 92a7fa5be11350dcf8d652d74f8c1762
+
+pkgname = python-pydna
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..478c2ae03d9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-pydna'
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="Python3 classes for dsDNA simulation of homologous recombination, Gibson assembly and interactive cloning"
+arch=('any')
+url="https://github.com/BjornFJohansson/pydna"
+license=('MIT')
+depends=(
+ 'python'
+ 'python-appdirs>=1.3.0'
+ 'python-biopython>=1.65'
+ 'python-networkx>=1.8.1'
+ 'python-orderedset>=2.0'
+ 'python-prettytable>=0.7.2'
+ 'python-pyparsing>=2.1.10'
+ 'python-requests'
+)
+makedepends=('python-setuptools')
+optdepends=(
+ 'python-matplotlib: gel simulation'
+ 'python-mpldatacursor: gel simulation'
+ 'python-numpy: gel simulation'
+ 'python-pint>=0.7.2: gel simulation'
+ 'python-scipy: gel simulation'
+)
+provides=('python-pydna')
+conflicts=('python-pydna')
+options=(!emptydirs)
+source=("https://github.com/BjornFJohansson/pydna/archive/${pkgver}.tar.gz")
+md5sums=('92a7fa5be11350dcf8d652d74f8c1762')
+
+package() {
+ cd "${srcdir}/pydna-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}